Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85666 - The kernel file may not contain a dot
Summary: The kernel file may not contain a dot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: syslinux
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-05 18:51 UTC by Lars Berntzon
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-11 23:21:34 UTC


Attachments (Terms of Use)

Description Lars Berntzon 2003-03-05 18:51:25 UTC
Description of problem:
I tried to setup a network installation with Linux using standard PXE (not the 
pxe-package that comes with RedHat-8.0) using standard DHCP and TFTP servers. 
When I called the kernel vmlinuz-8.0 it printed a garbage string on the screen 
just after the kernel was started (the pxelinux.0 started and parsed the 
configuration file ok though).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install standard DHCP and TFTP (I used windows-2000) 
2. Place the pxelinux.0 and a kernel named vmlinuz-8.0
3. Perform a PXE-boot of a client.
    
Actual results:
Crash

Expected results:
Normal boot

Additional info:

Comment 1 Matt Wilson 2003-03-05 19:00:17 UTC
what version of pxelinux?   This works fine here - we have plenty of configs
with . in them.

Comment 2 Ben LaHaise 2003-03-05 19:04:59 UTC
Works for me using a Red Hat 8 box as the dhcp+tftp server.  Note that some
older boot roms require use of the pxe package, whereas others can boot using
tftp.  Check the pxelinux FAQ for additional information on workarounds needed
for various boot rom bugs.

Comment 3 Lars Berntzon 2003-03-05 19:10:18 UTC
I have used a number of different versions of pxelinux and they all fail the 
same. The thing is (i forgot to mention that first) is that when booting a 
RedHat-7.2 kernel (with a dot in the name) it does work. My feeling is that 
the error is not in syslinux but in the actual kernel.

Comment 4 H. Peter Anvin 2003-04-11 06:37:57 UTC
This is not a bug.

A file ending in .0 is assumed to be a PXE NBP and not a Linux kernel file. 
This is documented in the SYSLINUX/PXELINUX documentation.


Comment 5 Peter Jones 2005-01-11 23:21:34 UTC
I'm closing this, given hpa's comment.


Note You need to log in before you can comment on or make changes to this bug.