Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85637 - On minimizing one gnome-terminal, another is brought to foreground
Summary: On minimizing one gnome-terminal, another is brought to foreground
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: metacity
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-05 12:05 UTC by Joe Orton
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-05 16:22:51 UTC


Attachments (Terms of Use)

Description Joe Orton 2003-03-05 12:05:58 UTC
Description of problem:
(I have no idea whether this is a bug in gnome-terminal, metacity, or something
else)

I have windows stacked in follow order from front to back:

gnome-terminal A, Mozilla, gnome-terminal B

Terminal A has focus, and I mininize it.  Now terminal B is brought in front of
Mozilla, which is not desired behaviour, surely? 8.0 didn't do this, I'm pretty
sure.

Version-Release number of selected component (if applicable):
metacity-2.4.34-3
gnome-terminal-2.2.1-3
vte-0.10.25-1

How reproducible:
Always

Steps to Reproduce:
1. bring up three windows, terminal, non-terminal, terminal in that order
2. minimize the top terminal
    
Actual results:
Back terminal is brought in front of non-terminal

Expected results:
Non-terminal is left and given focus.

Additional info:
Terminally annoying behaviour.

Comment 1 Havoc Pennington 2003-03-05 16:22:51 UTC
There's code where if you close a dialog it tries to focus the parent window 
of the dialog I think, perhaps that code is overzealous. If you run your 
terminals with --disable-factory it probably won't happen (because they won't be 
"in the same app") - perhaps a workaround.

Moving to http://bugzilla.gnome.org/show_bug.cgi?id=107654


Note You need to log in before you can comment on or make changes to this bug.