Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85631 - Cannot install Phoebe with Smart Boot Manager
Summary: Cannot install Phoebe with Smart Boot Manager
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: parted
Version: 9
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-05 09:36 UTC by Kazutoshi Morioka
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-06-25 18:56:05 UTC


Attachments (Terms of Use)

Description Kazutoshi Morioka 2003-03-05 09:36:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.8 (X11; Linux i686; U;) Gecko/20030212

Description of problem:
I'm using Smart Boot Manager (SBM) as a bootmanager.
Phoebe installer failed to detect patition table on my machine using SBM.
My machine's partition type was not detected correctly as msdos,
but as "loop" patition type (like a filesystem on floppy).
This is SBM's fault. not a bug of Phoebe installer nor GNU parted.
SBM incorrectly put a fat filesystem signature, "FAT12" in offset 0x36
bytes from beginning of disk.
So, GNU parted will think this is a raw FAT filesystem.
I tried to clear from offset 0x36 to 0x3a with SPACE code, 0x20.
Then, I can successfully install Phoebe.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install SBM into Master Boot Record.
2. Try to install Phoebe.
3. Proceed to disk-druid.
    

Actual Results:  Incorrect partition type "loop" is detected, and failed to install.

Expected Results:  Correctly detect "msdos" partition table, and diskdruid is
showing up.

Additional info:

What to be fixed is SBM.
Editing partition table with hexedit is easy for me,
But there is no other out-of-the-box solution for this problem.
Uninstalling SBM leave a FAT signature on the MBR.
So that, uninstalling SBM dose not solve this.
At least, please mention this in the RELEASE-NOTES.


Note You need to log in before you can comment on or make changes to this bug.