Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85623 - anaconda crash at line 94 in intf.run
Summary: anaconda crash at line 94 in intf.run
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-05 04:51 UTC by Dale Timko
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-07 19:48:31 UTC


Attachments (Terms of Use)
anaconda dump file (deleted)
2003-03-06 05:25 UTC, Dale Timko
no flags Details

Description Dale Timko 2003-03-05 04:51:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Traceback ( File " /usr/bin/anaconda", line 94 in ?
intf.run(id,dispatch,configFileData)
File "/usr/src/build/14865-i386/install//usr/1id/anaconda/text.py,
line425, in run

Version-Release number of selected component (if applicable):
8.0

How reproducible:
Always

Steps to Reproduce:
1.Selected upgrade of packages for existing 8.0 version
2.ISO files on hda5 (iso files on hard drive)
3.no upgrade to boot loader selected
    

Actual Results:  Crash in anaconda occurred as described above

Expected Results:  Expected to eventually get to selecting packages to upgrade.

Additional info:

Comment 1 Michael Lee Yohe 2003-03-05 18:41:52 UTC
You need to attach the traceback file to this bug that Anaconda generated.

Comment 2 Dale Timko 2003-03-06 03:07:02 UTC
Michael

I'm a newbie.

Please identify the path and file name of where traceback I can locate the
traceback.

Sorry

Comment 3 Dale Timko 2003-03-06 05:25:06 UTC
Created attachment 90486 [details]
anaconda dump file

Figured out what you wanted. Had to rerun the install to get to the save file.

Comment 4 Jeremy Katz 2003-03-07 19:48:31 UTC
This is fixed in our current codebase.  Workaround is to not select to upgrade
boot loader and instead either select do nothing or create a new boot loader
config (since it didn't detect a boot loader but still gave the option to
upgrade it)


Note You need to log in before you can comment on or make changes to this bug.