Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85595 - terminfo command for serial console broken
Summary: terminfo command for serial console broken
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 20:42 UTC by Dr. Tilmann Bubeck
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-02 05:53:00 UTC


Attachments (Terms of Use)
Patch to correct the problem. (deleted)
2003-03-04 20:43 UTC, Dr. Tilmann Bubeck
no flags Details | Diff

Description Dr. Tilmann Bubeck 2003-03-04 20:42:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

Description of problem:
Unfortunately the terminfo command to define terminfo sequences for serial
console is broken. The problem is, that grub does not "unescape" the read
terminfo sequences from "grub.conf". E.g. if "grub.conf" contains \e (two
characters), then this has to get ESC (a single character 0x1b), but doesn't.
The result is, that the terminal will not output the single ESC character but
will output \e (two characters). No escape sequence will work.

Another problem is, that the terminfo command without any arguments should
output the current settings but doesn't "escape" the current terminfo sequences.
So the terminal will _execute_ the terminfo sequence instead of displaying them
as a ascii text.

The last thing is, that the size of the terminfo structure entries is maybe too
small. It is currently 32 bytes, but some terminfo sequences are 29 bytes.
Probably some are longer. So I would suggest to make them at least 40 bytes.

Please find enclosed a patch to fix all of these 3 problems.

[This message was sent to the grub maintainers, too. However, rhat should fix
this problem otherwise no serial console apart from vt100 will work].



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attacha a serial console and use anything except vt100
2. define the terminfo command
3. see, that it doesn't work
    

Actual Results:  terminal does not use escape sequences. GRUB unusable.

Expected Results:  Screen ok.

Additional info:

Comment 1 Dr. Tilmann Bubeck 2003-03-04 20:43:04 UTC
Created attachment 90467 [details]
Patch to correct the problem.

Comment 2 Jeremy Katz 2003-04-02 05:53:00 UTC
Added in 0.93-5


Note You need to log in before you can comment on or make changes to this bug.