Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85584 - usb keyboard blinks out
Summary: usb keyboard blinks out
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 19:04 UTC by Mike McLean
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-20 23:42:06 UTC


Attachments (Terms of Use)

Description Mike McLean 2003-03-04 19:04:04 UTC
* -re0227.....
* kernel-2.4.20-6

This has happened twice in the last 20 minutes.  The machine is a Proliant
ML330e with usb kbd and mouse attached, no ps/2 at all right now.

The first time this happened, it seemed to have happened mid-keystroke, since X
was behaving as if the ALT key was pressed (judging by mouse drag behavior). 
The second time, mouse drag behavior was normal.

Both times, I logged in remotely and ran xev.  It did not receive any keystroke
events.  The caps-lock key on the keyboard would not light up.  

Nothing unusual appeared in the system logs.

The first time, the problem disappeared when I switched the console with chvt. 
The second time, it seemed to disappear on it's own.

Comment 1 Mike McLean 2003-03-04 19:04:48 UTC
[root@test114 root]# cat /proc/bus/usb/devices
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 4
B:  Alloc=211/900 us (23%), #Int=  2, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB OHCI Root Hub
S:  SerialNumber=d483f000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms
T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=03ee ProdID=5601 Rev= 1.00
S:  Product=Mitsumi USB Keyboard
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=01 Driver=hid
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#=  3 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=047d ProdID=1001 Rev= 1.00
S:  Manufacturer=Kensington
S:  Product=Kensington USB/PS2 Wheel Mouse
C:* #Ifs= 1 Cfg#= 1 A Wheel Mouse
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=hid
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=10ms


Comment 2 Mike McLean 2003-04-04 18:44:42 UTC
I keep seeing this periodically.  Different keys seem to get °stuck° and no
other key will work.  Yesterday it was A,  today it appears to be capslock.

I found the following message in /var/log/messages:

Apr  4 13:31:06 test114 kernel: hid-core.c: ctrl urb status -110 received

this appeared both today and yesterday at about the time the problem occured.


Comment 3 Pete Zaitcev 2003-06-03 02:25:11 UTC
Mike, I'm generally at loss about this, but if this box is SMP, you probably
want to try the latest gingin errata, which has the fix for usb-ohci (bug 84814).
Your use of OHCI is the only clue to your bug currently.


Comment 4 Pete Zaitcev 2003-06-03 19:08:06 UTC
BTW, it is essential to use 2.4.20-18. There was a raft of problems
with usb in 2.4.20-13 (unlucky selection of upstreadm tree, nyah nyah :-()


Comment 5 Pete Zaitcev 2004-01-20 04:38:16 UTC
Tried on Fedora yet?


Comment 6 Mike McLean 2004-01-20 22:30:39 UTC
I have never been able to reproduce this reliably.  It was just
something that happened on my workstation a few times.

My workstation has since been upgraded to Fedora and I haven't seen
the problem since.


Note You need to log in before you can comment on or make changes to this bug.