Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85575 - konqueror segfault when copying files
Summary: konqueror segfault when copying files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 17:23 UTC by Chris Ricker
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-03 15:47:42 UTC


Attachments (Terms of Use)

Description Chris Ricker 2003-03-04 17:23:04 UTC
Fresh install of beta 5 (kdebase-3.1-7)

I get the following traceback when doing copies of a large number of files (~600
megs or more of ~10 meg files). I was doing this from one NFS share to another
NFS share

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1092520352 (LWP 1627)]
0xffffe002 in ?? ()
#0  0xffffe002 in ?? ()
#1  0x4063957d in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#2  <signal handler called>
#3  0x401ff26b in KFileItem::mimetype() const () from /usr/lib/libkio.so.4
#4  0x4021e331 in KIO::MetaInfoJob::getMetaInfo() () from /usr/lib/libkio.so.4
#5  0x4021e158 in KIO::MetaInfoJob::determineNextFile() ()
   from /usr/lib/libkio.so.4
#6  0x4021e19e in KIO::MetaInfoJob::slotResult(KIO::Job*) ()
   from /usr/lib/libkio.so.4
#7  0x4021dae9 in KIO::MetaInfoJob::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkio.so.4
#8  0x409b90c9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#9  0x401797d2 in KIO::Job::result(KIO::Job*) () from /usr/lib/libkio.so.4
#10 0x40165857 in KIO::Job::emitResult() () from /usr/lib/libkio.so.4
#11 0x40166dae in KIO::SimpleJob::slotFinished() () from /usr/lib/libkio.so.4
#12 0x401696be in KIO::TransferJob::slotFinished() () from /usr/lib/libkio.so.4
#13 0x4017afcd in KIO::TransferJob::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkio.so.4
#14 0x409b90c9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#15 0x409b8f6d in QObject::activate_signal(int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#16 0x4015c00e in KIO::SlaveInterface::finished() () from /usr/lib/libkio.so.4
#17 0x4015ae1d in KIO::SlaveInterface::dispatch(int, QMemArray<char> const&) ()
   from /usr/lib/libkio.so.4
#18 0x4015a4c9 in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.4
#19 0x4015811b in KIO::Slave::gotInput() () from /usr/lib/libkio.so.4
#20 0x40159bd0 in KIO::Slave::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkio.so.4
#21 0x409b90c9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#22 0x409b91a5 in QObject::activate_signal(int, int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#23 0x40c99282 in QSocketNotifier::activated(int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#24 0x409d54b0 in QSocketNotifier::event(QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#25 0x4095af24 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#26 0x4095ab19 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#27 0x405cd1e9 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#28 0x40935efa in QEventLoop::activateSocketNotifiers() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#29 0x409138d7 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#30 0x4096ecf6 in QEventLoop::enterLoop() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#31 0x4096eb98 in QEventLoop::exec() () from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#32 0x4095b151 in QApplication::exec() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#33 0x4129f3e7 in main () from /usr/lib/konqueror.so
#34 0x0804ca81 in strcpy ()
#35 0x0804d73b in strcpy ()
#36 0x0804dbec in strcpy ()
#37 0x0804e8f9 in strcpy ()
#38 0x420154a0 in __libc_start_main () from /lib/tls/libc.so.6

Comment 1 Ngo Than 2003-06-03 15:47:42 UTC
i cannot reproduce this problem at least in KDE 3.1.2, which is available in rawhide


Note You need to log in before you can comment on or make changes to this bug.