Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85574 - microcode_ctl should not use /usr/bin/head
Summary: microcode_ctl should not use /usr/bin/head
Keywords:
Status: CLOSED DUPLICATE of bug 82396
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-utils
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 16:16 UTC by Enrico Scholz
Modified: 2015-01-04 22:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-26 03:12:57 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2003-03-04 16:16:35 UTC
Description of problem:

/etc/init.d/microcode_ctl is executed very early in the boot-process but
executes commands located under /usr/bin

|        vendor=`cat /proc/cpuinfo | \
|            grep "^vendor_id" | head -1 | \
|        ...

When /usr is mounted via NFS, the 'head' command will not be found.

I suggest to use "sed -e '2,$d'" instead of "head -1".


Version-Release number of selected component (if applicable):

kernel-utils-2.4-8.29

Comment 1 Dave Jones 2004-10-26 03:12:57 UTC

*** This bug has been marked as a duplicate of 82396 ***


Note You need to log in before you can comment on or make changes to this bug.