Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85563 - No way to uninstall KDE (or Gnome) in the Desktops category after installation
Summary: No way to uninstall KDE (or Gnome) in the Desktops category after installation
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 14:14 UTC by Mikael Carneholm
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-02 06:04:11 UTC


Attachments (Terms of Use)

Description Mikael Carneholm 2003-03-04 14:14:45 UTC
If you choose to install f.eg. both Gnome and KDE during installation
and afterwards want to uninstall f.eg. KDE, there is no way to do this.

Steps to reproduce the problem:
1. Start redhat-config-packages
2. Realise that there is no way to remove f.eg. KDE (if it is
installed)
3. Done

Actual Results:
No checkboxes besides the "KDE Desktop Environment" and "Gnome Desktop
Environment" labels that allows you to check/uncheck a group of packages
(for installation/uninstallation)

Expected Results:
A checkbox besides the "KDE Desktop Environment" and "Gnome Desktop
Environment" labels that allows you to check/uncheck a group of packages
(for installation/uninstallation)

How often does this happen?
Every time.

Additional Information:
This should be possible (can't see why one should not be able to
uninstall one of the desktop environments after installation)?

Comment 1 Jeremy Katz 2003-04-02 06:04:11 UTC
This is by design to avoid users who don't know better uninstalling their
desktop environment and breaking their systems.


Note You need to log in before you can comment on or make changes to this bug.