Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85560 - Metacity is missing important window positioning features.
Summary: Metacity is missing important window positioning features.
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: metacity
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 12:41 UTC by Veit Wahlich
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-04 16:23:52 UTC


Attachments (Terms of Use)

Description Veit Wahlich 2003-03-04 12:41:24 UTC
Description of problem:
As in sawfish I need some window positioning features. Especially because this
is a multiscreen system, I need to control at least on which screen new windows
pop up.
Metacity seems to behave that it creates the Window on the first screen that has
enough space for the window.

The following features should be implemented to ensure productive work:

1. Ability to save a window's current state:
 - position on screen(s)
 - window size
 - window status (maximized, minimized)
 - visible on all workspaces

2. Ability to release/forget the states.

3. Window placement behavior control:
 - best fit
 - under mouse pointer
 - always on screen #
 - always at absolute screen position x,y


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Example:
1. Open a window.
2. Set it visible on all work spaces.
3. Close the window.
4. You need to set it visisible on all ws again.

Actual Results:  Missing window placement control.

Expected Results:  Having window placement control.

Additional info:

Comment 1 Havoc Pennington 2003-03-04 16:23:52 UTC
Some of this is planned, it's tracked on bugzilla.gnome.org. Specifically 
auto-position-recording and some tweaks to placement.
For what is not planned you will need to use another window manager, 
metacity is only a basic window manager.
See bugzilla.gnome.org bug reports for full discussion, can add comments there.


Note You need to log in before you can comment on or make changes to this bug.