Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85538 - Font rendering much worse than 8.0
Summary: Font rendering much worse than 8.0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: fontconfig
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 02:07 UTC by Tom Sightler
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-23 23:13:38 UTC


Attachments (Terms of Use)

Description Tom Sightler 2003-03-04 02:07:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
I had a Dell Latitude C810 (1.13Mhz PIII) with a 16MB NVidia Geforce2Go running
Redhat 8 using the NVidia binary drivers.  I recently upgraded this system to
Phoebe Beta 3.

After applying the appropriate patches to make the Nvidia driver compile with
the Phoebe 2.4.20-2.48 kernel and disabling TLS everything seems to work fine
overall except for font rendering.

Compared to Redhat 8 the font rendering in Phoebe is significantly worse.  It
appears to be some type of issue with sub-pixel rendering not  fully working or
at least not working as well as the fonts have outlines of blue and red (it
almost make my laptop display look like a CRT with bad convergence).  

Playing with the sub-pixel rendering settings does improve the view but in no
case is it anywhere near as clear as with Redhat 8.  The problem is also much
less noticable if I run the screen at it's maximum resolution (1600x1200),
however, I usually run at a much lower 1024x768.

I'm not sure what other information I can provide but let me know what else I
can do to help.  I don't see any significant changes to the core font rendering
and wonder if the problem could come from the Xserver itself.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up into 1024x768 mode on Dell Latitude Laptop


Actual Results:  Characters are not very clear on laptop display

Expected Results:  Characters should be at least as clear as Redhat 8

Additional info:

Comment 1 Tom Sightler 2003-03-23 23:13:38 UTC
This appears to be somehow related to an interaction with the NVidia binary
drivers and XFree86 4.3 and not directly related to fontconfig.  I downgraded my
XFree to 4.2 from Redhat 8.0 and the font rendering is back to normal.  The
standard nv that comes with 4.3 also seems to work correctly.

I will report this issue to NVidia.

Sorry for the eroneous report, I thought I had tested this with the default 'nv'
driver before reporting this, apparently I had not.

Tom



Note You need to log in before you can comment on or make changes to this bug.