Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85532 - GREP (regex) broken.
Summary: GREP (regex) broken.
Keywords:
Status: CLOSED DUPLICATE of bug 76328
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grep
Version: 8.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-03 22:48 UTC by Need Real Name
Modified: 2006-02-21 18:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:05 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-03-03 22:48:16 UTC
Description of problem: Regular expression in grep is misinterpreted/broken. It 
works on FreeBSD. It seems to effect all programs using regular expression.


Version-Release number of selected component (if applicable): grep-2.5.1-4


How reproducible:very


Steps to Reproduce: 
Using file: testgrep.txt
abcXYZ
abcd
XYZ

1. 
Actual results:

grep [A-Z] testgrep.txt   - DOES NOT WORK! Lower case "abcd" should not printed.
abcXYZ
abcd
XYZ

grep [YZ] testgrep.txt        - WORKS!
abcXYZ
XYZ

grep [a-z] testgrep.txt       - DOES NOT WORK! Should not print XYZ
abcXYZ
abcd
XYZ

grep [Y-Z] testgrep.txt       - WORKS!
abcXYZ
XYZ


Expected results: As described above. It works properly on FreeBSD.

Additional info: Probably a broken regex C library routine. As this is a basic 
routine used in so many commands and applications, it is A VERY SERIOUS ERROR.

Comment 1 Mike McLean 2003-03-03 23:08:05 UTC


*** This bug has been marked as a duplicate of 76328 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.