Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85531 - (SOUND EMU10K1)Sound Blaster live no more working when update to kernel-2.4.18-24.8.0
Summary: (SOUND EMU10K1)Sound Blaster live no more working when update to kernel-2.4.1...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-03 22:47 UTC by Olivier PETIT
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-10 17:46:42 UTC


Attachments (Terms of Use)

Description Olivier PETIT 2003-03-03 22:47:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have installed a Red Hat 8.0 from CD. The Kernel version was kernel-2.4.18-14
and my Sound Blaster Live! 5.1 was corectly detected during the install process.
After the first reboot, it works perfectly.

I have updated my kernel to 2.4.18-24.8.0 which is the last available, via
redhat Network  and after reboot, my Sound Blaster was no more available. No
sound, nothing in the mixer (it's probably important to say that before I have
also a USB Philips webcam visible in the mixer because it has a microphone on
it, and after the upgrade, the webcam was no more on mixer too). 

I have tried to set up again with sndconfig. It is corectly detected, but when
sndconfig tries to plays a sound, nothing.

I have rebooted again, but on 2.4.18-14 -the "old" version, and the situation is
the same : No more sound. So after this update, there's no more solution to have
any sound.

I have installed Redhat again, and the issue happened again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat 8.0 from CD (kernel version 2.4.18-14) 
2.Update to kernel 2.4.18-24.8.0 via Red Hat Network
3.Look a the mixer and try to play sound
    

Actual Results:  No sound available, no sound peripherals, especially Sound
Blaster Live! 5.1

Expected Results:  The sound should be ok, as the module emu10k1.o is in the
/lib/modules/2.4.18-24.8.0/kernel/drivers/sound/emu10k1 folder

Additional info:

No idea of what happened...

Comment 1 Alan Cox 2003-06-10 17:46:42 UTC
Fixed in the 2.4.20 based futher errata kernel



Note You need to log in before you can comment on or make changes to this bug.