Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85529 - Error -110 writing Tx descriptor to BAP
Summary: Error -110 writing Tx descriptor to BAP
Keywords:
Status: CLOSED DUPLICATE of bug 75237
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-03 22:39 UTC by Tim Keitt
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:05 UTC


Attachments (Terms of Use)

Description Tim Keitt 2003-03-03 22:39:15 UTC
Description of problem:

I get multiple "Error -110 writing Tx descriptor to BAP" messages in my logs
after which my wireless connection dies. The orinoco_pci module is the culprit.
If I do "ifdown eth1; modprobe -r ornico_pci; modprobe orinoco_pci; ifup eth1" I
usually, but not always, get my connection back.

Here's the relevant bits of 'lspci -v':

01:0d.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset (rev
01)
        Subsystem: Citicorp TTI: Unknown device 1169
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at e0300000 (32-bit, prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Version-Release number of selected component (if applicable):

/* orinoco_pci.c 0.01
 *
 * Driver for Prism II devices that have a direct PCI interface
 * (i.e., not in a Pcmcia or PLX bridge)
 *
 * Specifically here we're talking about the Linksys WMP11
 *
 * Some of this code is borrowed from orinoco_plx.c
 *      Copyright (C) 2001 Daniel Barlow <dan@telent.net>
 * Some of this code is "inspired" by linux-wlan-ng-0.1.10, but nothing
 * has been copied from it. linux-wlan-ng-0.1.10 is originally :
 *      Copyright (C) 1999 AbsoluteValue Systems, Inc.  All Rights Reserved.
 * The rest is :
 *      Copyright (C) 2001 Jean Tourrilhes <jt@hpl.hp.com>
 *

How reproducible: always

Steps to Reproduce:
1. buy Fujitsu (Lifebook S) laptop
2. install redhat 8
3. buy linksys wireless router
4. setup wireless network
5. prepare to be frustrated
    
Actual results: It doesn't work

Expected results: It works


Additional info:

I think this is a known bug, but I would like to make sure its in the queue to
be fixed.

Comment 1 Tim Keitt 2003-03-17 03:22:21 UTC

*** This bug has been marked as a duplicate of 75237 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.