Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85477 - Segmentation fault on GIF conversion
Summary: Segmentation fault on GIF conversion
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netpbm
Version: 8.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-03 16:24 UTC by Boris Folgmann
Modified: 2015-03-05 01:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-09 15:41:42 UTC


Attachments (Terms of Use)
GIF that triggers the seg fault (deleted)
2003-03-03 16:25 UTC, Boris Folgmann
no flags Details

Description Boris Folgmann 2003-03-03 16:24:12 UTC
Description of problem:
I regularly use netpbm-tools for making non-interlaced GIFs interlaced. With
three new pictures I get a segmentation fault. With my old images it still works.

Version-Release number of selected component (if applicable):
netpbm-progs-9.24-3

How reproducible:
Always, see below

Steps to Reproduce:
1. giftopnm silver_border.gif | ppmtogif -interlace >silver_border_interlaced.gif
    
Actual results:
ppmtogif: computing colormap...
ppmtogif: 29 colors found
Segmentation fault


Expected results:
giftopnm works, but pptogif dumps core

Additional info:
I attach the picture for you.

Comment 1 Boris Folgmann 2003-03-03 16:25:52 UTC
Created attachment 90452 [details]
GIF that triggers the seg fault

Comment 2 Boris Folgmann 2003-03-03 16:36:03 UTC
It seems to be a problem of the -interlace code, because it works without these
option, but of course that is not what I want to have.


Comment 3 Boris Folgmann 2003-07-22 16:57:42 UTC
Same problem with RedHat 8.0, netpbm-progs-9.24-9.80.2.


Comment 4 Phil Knirsch 2004-02-09 15:41:42 UTC
Fixed in latest netpbm-10.19-2 available via rawhide.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.