Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85469 - Error making Nvidia kernel driver using Nvidia driver version 4191
Summary: Error making Nvidia kernel driver using Nvidia driver version 4191
Keywords:
Status: CLOSED DUPLICATE of bug 73733
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-03 08:10 UTC by Ray Cordoni
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:03 UTC


Attachments (Terms of Use)

Description Ray Cordoni 2003-03-03 08:10:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
I am trying to install the version 4191 Nvidia video drivers on phoebe 8.0.94
(third beta).  The first step is to compile the kernel driver from the Nvidia
source.  This fails with many errors ending in "make: *** [nv.o] Error 1".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download and untar the latest Nvidia drivers (Kernel Tar File) to an install
directory.
2. cd NVIDIA_kernel-1.0-4191
3. make install

    

Actual Results:  echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -1`\" >
nv_compiler.h
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts
-Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar  -O -MD -D__KERNEL__
-DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES
-D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0
-DNV_PATCHLEVEL=4191  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86     
 -I. -I/lib/modules/2.4.20-2.48/build/include -Wno-cast-qual nv.c
In file included from /lib/modules/2.4.20-2.48/build/include/linux/vmalloc.h:8,
                 from nv-linux.h:64,
                 from nv.c:14:
/lib/modules/2.4.20-2.48/build/include/linux/highmem.h: In function `bh_kmap':
/lib/modules/2.4.20-2.48/build/include/linux/highmem.h:20: warning: pointer of
type `void *' used in arithmetic
nv.c: In function `nv_kern_mmap':
nv.c:1282: warning: passing arg 1 of `remap_page_range_R839d959e' makes pointer
from integer without a cast
nv.c:1282: incompatible type for argument 4 of `remap_page_range_R839d959e'
nv.c:1282: too few arguments to function `remap_page_range_R839d959e'
nv.c:1301: warning: passing arg 1 of `remap_page_range_R839d959e' makes pointer
from integer without a cast
nv.c:1301: incompatible type for argument 4 of `remap_page_range_R839d959e'
nv.c:1301: too few arguments to function `remap_page_range_R839d959e'
nv.c:1387: warning: passing arg 1 of `remap_page_range_R839d959e' makes pointer
from integer without a cast
nv.c:1387: incompatible type for argument 4 of `remap_page_range_R839d959e'
nv.c:1387: too few arguments to function `remap_page_range_R839d959e'
nv.c: In function `nv_get_phys_address':
nv.c:2250: warning: implicit declaration of function `pte_offset'
nv.c:2250: invalid type argument of `unary *'
make: *** [nv.o] Error 1


Expected Results:  A file called NVdriver should have been created in the
/lib/modules/2.4.20-2.48/kernel/drivers/video directory.

Additional info:

I don't know if this is an Nvidia problem or a Redhat problem.  I am posting it
here in the hopes that someone can recognize what is wrong and what I need to do
to fix it.  My system was running Redhat 8.0 and Nvidia driver version 2960 OK
prior to installing phoebe.

Comment 1 Arjan van de Ven 2003-03-03 19:09:57 UTC

*** This bug has been marked as a duplicate of 73733 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.