Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85468 - RedHat 8 no Scandinavian characters
Summary: RedHat 8 no Scandinavian characters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gedit
Version: 8.0
Hardware: i586
OS: Linux
high
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-03 07:49 UTC by anzac
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-03 18:28:36 UTC


Attachments (Terms of Use)

Description anzac 2003-03-03 07:49:05 UTC
Description of problem:
I cannot use Finnish characters in any documents/scripts using any supplied
editor even though I selected Finnish and English(GB) during installation. In
both KDE and Gnome I have selected Finnish keyboard.  Have tried to use SETUP to
specify the keyboard to use to no avail.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.Open an editor (kedit,gedit)
2.Write a script. For example PHP.
3.Use scandinavian characters and view using Mozilla. 
    
Actual results:
Rubbish characters will result.

Expected results:
Scandinavian characters

Additional info:

Comment 1 anzac 2003-03-07 11:12:03 UTC
Since posting this message I have attempted many different clean installs always
with the same result. When I select FI-latin1 or SE-Latin1, during install and
set locale and keyboard correctly after install, RedHat8 refuses to use/show
Scandinavian characters in my programs/scripts when they run in the Internet.
RedHat 8 'ignores' browser character set selections by users of my programs. The
behaviour is not browser-dependant. During boot, Redhat boot scripts do not
accept some characters in the RedHat keytable. A typical boot log has been sent
to RedHat support. The log-on screen is in Finnish, KDE shows Finnish text as
does Gnome but obviously that is not enough for a programmer!

Comment 2 Havoc Pennington 2003-07-30 22:16:14 UTC
gedit probably saves in UTF-8, what encoding are you using in Mozilla?

We need to make a list of exact cases where things break, and then 
break this bug into separate bugs for each app that has problems.

For example, if Mozilla defaults to an encoding other than the locale 
encoding for viewing local files, that is probably wrong.

If you run the command "locale" what is the output?

Comment 3 Havoc Pennington 2003-08-05 21:13:07 UTC
Please move bug out of NEEDINFO if you add more details.

Comment 4 Havoc Pennington 2004-11-03 18:28:36 UTC
Closing as RHL8 is no longer relevant


Note You need to log in before you can comment on or make changes to this bug.