Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85466 - Tuxracer doesn't gets compiled with sound because of mallformed patch
Summary: Tuxracer doesn't gets compiled with sound because of mallformed patch
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: tuxracer
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
: 102234 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-03-03 06:20 UTC by Michal Ambroz
Modified: 2007-04-18 16:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-14 08:55:45 UTC


Attachments (Terms of Use)
Corected patch tuxracer-0.61-config.patch (deleted)
2003-03-03 06:23 UTC, Michal Ambroz
no flags Details | Diff

Description Michal Ambroz 2003-03-03 06:20:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Hello,

tuxracer game by mistake doesn't gets compiled with sound support in Phoebe-3
8.0.94. 

This is caused by patch "tuxracer-0.61-config.patch" which wants to link test
code in ./configure script against smpeg library - which is wrong because there
is not such library in nowdays RedHat.

It looks like this:
   ac_save_LIBS="$LIBS"
-LIBS="-lSDL_mixer  $LIBS"
+LIBS="-lSDL_mixer -lsmpeg  $LIBS"
 cat > conftest.$ac_ext <<EOF

When two chunks adding this library are removed from this patch, it gets
compiled well and what is important it plays sounds :).



Version-Release number of selected component (if applicable):
tuxracer-0.61-19


How reproducible:
Always

Steps to Reproduce:
1. get the src.rpm package tuxracer-0.61-19.src.rpm

2. try to recompile it with:
   rpmbuild --rebuild tuxracer-0.61-19.src.rpm




  

Actual Results: 
 You 'll see this during configuration:
   checking for SDL - version >= 1.0.1... yes
   checking for SDL_JoystickOpen... yes
   checking for Mix_OpenAudio in -lSDL_mixer... no
   *** SDL_mixer not found.  Configuring without audio support.


Expected Results: compile with sound support and play sounds
   checking for SDL - version >= 1.0.1... yes
   checking for SDL_JoystickOpen... yes
   checking for Mix_OpenAudio in -lSDL_mixer... yes




Additional info:

Comment 1 Michal Ambroz 2003-03-03 06:23:15 UTC
Created attachment 90449 [details]
Corected patch tuxracer-0.61-config.patch

This is the original patch with two problematic chunks removed

Comment 2 Nils Philippsen 2003-08-13 18:33:33 UTC
*** Bug 102234 has been marked as a duplicate of this bug. ***

Comment 3 Nils Philippsen 2003-08-13 18:35:57 UTC
Bumped product to Red Hat Linux Beta.

Comment 4 Ngo Than 2003-08-14 08:55:45 UTC
it's fixed in tuxracer-0.61-22. thanks for your info.

Comment 5 Elton Woo 2003-08-16 05:42:12 UTC
I did not compile from source, but installed the version in the Severn beta 1 
(RH 9.0.93). Sound now works in the game after upgrading from rawhide to 
tuxracer-0.61-23 
 


Note You need to log in before you can comment on or make changes to this bug.