Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 854571 - New snapshot is not created when child channel is added/removed via spacewalk-channel.
Summary: New snapshot is not created when child channel is added/removed via spacewalk...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API
Version: 550
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 854581 (view as bug list)
Depends On:
Blocks: 819027 sat560-triage
TreeView+ depends on / blocked
 
Reported: 2012-09-05 10:55 UTC by Dimitar Yordanov
Modified: 2013-07-18 09:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-18 09:52:15 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2012-09-05 10:55:51 UTC
Description of problem:
 New snapshot is not created when child channel is added/removed via spacewalk-channel.

Version-Release number of selected component (if applicable):
Satellite [541|550]

How reproducible:
100%

Steps to Reproduce:
1. Create Custom Base Channel and Custom Child Channel.
2. Register a System.
3. Set the "Custom Base Channel" as a Base channel for the system.
4. Add "Custom Child Channel" to  the system using spacewalk-channel

  spacewalk-channel --add -c ${CHILD_CUSTOM_CHANNEL} --user=${RHN_USER}  --password=${RHN_PASS}"
 
Actual results:
When the child chanel is added  new snapshot is not created in
Systems -> the System profile -> Provisioning -> Snapshots

Expected results:
New snapshot is  created.

Additional info:
The same issue was solve for API calls in 
Bug 809579 - New snapshot is not created when Entitlements are added to a system via API.

Comment 1 Dimitar Yordanov 2012-09-05 11:26:32 UTC
Bug 854581 - New snapshot is not created when child channel is added/removed via API.

Comment 2 Clifford Perry 2013-07-08 15:13:45 UTC
*** Bug 854581 has been marked as a duplicate of this bug. ***

Comment 3 Tomas Lestach 2013-07-18 09:52:15 UTC
As rhn-channel is a symlink to spacewalk-channel

ll /usr/sbin/rhn-channel 
lrwxrwxrwx. 1 root root 17 Mar  7 14:48 /usr/sbin/rhn-channel -> spacewalk-channel

this looks like a duplicate of Bug 857635. Closing.

*** This bug has been marked as a duplicate of bug 857635 ***


Note You need to log in before you can comment on or make changes to this bug.