Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85435 - (NPTL kernel) xmms doesn't run at all, SIGSEGV
Summary: (NPTL kernel) xmms doesn't run at all, SIGSEGV
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: xmms
Version: phoebe
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 97367 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-02 18:38 UTC by Kjetil T. Homme
Modified: 2014-03-17 02:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-04 03:54:44 UTC


Attachments (Terms of Use)
strace of crashing xmms (deleted)
2003-03-02 18:39 UTC, Kjetil T. Homme
no flags Details

Description Kjetil T. Homme 2003-03-02 18:38:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
xmms simply will not work :-)

it does work if I use the LD_ASSUME_KERNEL workaround to disable NPTL.

see also bug 81707.  this may be a glibc or kernel bug rather than xmms.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
run xmms

    

Actual Results:  
: [kjetilho@groucho ~]; xmms
mcop warning: user defined signal handler found for SIG_PIPE, overriding
Segmentation fault


Additional info:

I run a SMP system with dual Celeron 366.

kernel-smp-2.4.20-2.48
glibc-2.3.1-46
xmms-1.2.7-19.p

no extra plugins, clean install.

Comment 1 Kjetil T. Homme 2003-03-02 18:39:58 UTC
Created attachment 90444 [details]
strace of crashing xmms

Comment 2 Warren Togami 2003-03-03 02:59:47 UTC
Bug 81707 was a bug in libmpg123.so which does not ship in Red Hat Linux.  This
may be a different issue.

Comment 3 Bill Nottingham 2003-03-03 21:22:38 UTC
Is your libGL stock?

Comment 4 Kjetil T. Homme 2003-03-03 23:47:02 UTC
wow, I'm most impressed :-)

my libGL.so was a remnant from an NVidia driver installation.  I didn't think of
it since I'm now using the stock XFree86 driver, doh.  I cleared it out, and
xmms works.  thanks!


Comment 5 Bill Nottingham 2003-03-04 03:54:44 UTC
Closing, then, as it's not an xmms issue.

Comment 6 Bill Nottingham 2003-06-13 18:54:52 UTC
*** Bug 97367 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.