Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85425 - rpm -e portmap gives error reading information on service portmap: No such file or directory
Summary: rpm -e portmap gives error reading information on service portmap: No such fi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: portmap
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-02 06:04 UTC by Jean-Christian Imbeault
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-12 18:27:02 UTC


Attachments (Terms of Use)

Description Jean-Christian Imbeault 2003-03-02 06:04:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
Cannot rpm -e portmap. If I try I get the following error:

# rpm -e portmap
error reading information on service portmap: No such file or directory
error: %preun(portmap-4.0-46) scriptlet failed, exit status 1

According to my rpm db the portmap rpm *is* installed.

# rpm --rebuilddb
# rpm -qa | grep portmap
portmap-4.0-46



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -e portmap    

Actual Results:  error reading information on service portmap: No such file or
directory
error: %preun(portmap-4.0-46) scriptlet failed, exit status 1


Additional info:

I am using a custom 2.4.20 kernel if that makes a difference.

Comment 1 Jeff Johnson 2003-03-05 01:09:18 UTC
You can remove if you add --noscripts.

Otherwise, this is a portmap packaging problem.

Comment 2 Jean-Christian Imbeault 2003-03-05 02:15:44 UTC
Thanks, I did finally remove the rpm using --noscripts. However I would hope
that the rpm will be fixed so that this error does not come up.

To me this is a bug and hence needs to be fixed :)

Comment 3 Jean-Christian Imbeault 2003-03-05 10:09:35 UTC
Sorry, I posted before actually trying ... using --noscript did not help

# rpm -qa | grep portmap
portmap-4.0-46
# rpm -e --noscript portmap
error reading information on service portmap: No such file or directory
error: %preun(portmap-4.0-46) scriptlet failed, exit status 1


Comment 4 Steve Dickson 2004-08-12 18:27:02 UTC
This seems to be fixed in later portmap rpms.


Note You need to log in before you can comment on or make changes to this bug.