Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85423 - top displays bad output for artsd process
Summary: top displays bad output for artsd process
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: procps
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Brian Brock
URL:
Whiteboard:
: 85552 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-02 00:08 UTC by Jon Burgess
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-14 14:56:09 UTC


Attachments (Terms of Use)

Description Jon Burgess 2003-03-02 00:08:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
top shows the artsd process strangely, it looks like it has a nice value of
446744073709551565



Version-Release number of selected component (if applicable):
procps-2.0.11-3
Linux cele 2.4.20-2.48 #1 Thu Feb 13 11:52:55 EST 2003 i686 i686 i386 GNU/Linux



How reproducible:
Didn't try

Steps to Reproduce:
1. run top
2. Look for artsd process
3.
    

Actual Results:    PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME
CPU COMMAND
2179 root     18446744073709551565   0  1552  452   232 S     0.0  0.2   0:01  
0 artsd



Expected Results:  ps shows reasonable values
[root@cele RedHat-8.0.94]# ps -l -C artsd
F S   UID   PID  PPID  C PRI  NI ADDR    SZ WCHAN  TTY          TIME CMD
4 S     0  2179     1  0   9   0    -  2194 schedu ?        00:00:01 artsd



Additional info:
Fresh install of Phoebe3
PC is oldish x86 Celeron

Comment 1 Alexander Larsson 2003-03-11 13:18:43 UTC
Very strange. 
Can you try with 2.0.11-6 from rawhide:
http://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/procps-2.0.11-6.i386.rpm

Note that that version requires a kernel >= 2.4.20-2.50. So you probably have to
upgrade that to.



Comment 3 Jon Burgess 2003-03-11 13:54:40 UTC
OK, I updated the kernel and procps packages with no effect:

[root@cele rawhide]# uname -a
Linux cele 2.4.20-2.54 #1 Sat Feb 22 08:27:12 EST 2003 i686 i686 i386 GNU/Linux
[root@cele rawhide]# top -V
procps version 2.0.11
[root@cele rawhide]# rpm -q procps
procps-2.0.11-6

Top output sorted by memory use (press key M)

 13:45:01  up 1 day, 29 min,  6 users,  load average: 0.41, 0.11, 0.03
84 processes: 83 sleeping, 1 running, 0 zombie, 0 stopped
CPU states:   4.8% user   0.8% system   0.0% nice   0.0% iowait  94.2% idle
Mem:   158308k av,  155620k used,    2688k free,       0k shrd,   26976k buff
                    124240k actv,    7316k in_d,    2416k in_c
Swap:  321292k av,   16484k used,  304808k free                   73964k cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
 3159 root      15   0  7736 7712  1056 S     0.0  4.8   0:06   0 rhn-applet-gui
 3261 root      15   0  5904 5868  2740 S     0.5  3.7   0:05   0 kdeinit
 3002 root      15   0 19264 5564   588 S     4.2  3.5   1:02   0 X
 3153 root      15   0  5476 5476  2536 S     0.0  3.4   0:02   0 kdeinit
 3149 root      15   0  4300 4300  1872 S     0.0  2.7   0:02   0 kdeinit
 3151 root      15   0  4052 4052  1576 S     0.0  2.5   0:03   0 kdeinit
 3140 root      15   0  3780 3780  1052 S     0.0  2.3   0:01   0 kdeinit
 3168 root      15   0  3396 3384   428 S     0.0  2.1   0:04   0 kdeinit
 3121 root      15   0  2900 2900   736 S     0.0  1.8   0:02   0 kdeinit
 3157 root      15   0  2444 2444   224 S     0.0  1.5   0:00   0 kdeinit
 1733 ntp       15   0  2392 2392  2152 S     0.0  1.5   0:00   0 ntpd
 3131 root     18446744073709551565   0  2320 2320  1020 S     0.0  1.4   0:00 
 0 artsd
 3160 root      15   0  2248 2248   972 S     0.0  1.4   0:00   0 eggcups
...



Comment 4 Alexander Larsson 2003-03-11 14:52:33 UTC
What does /proc/3131/stat contain?


Comment 5 Jon Burgess 2003-03-11 15:18:31 UTC
root@cele tmp]# cat /proc/3131/stat
3131 (artsd) S 3113 3113 3113 0 -1 256 226 200 2277 520 47 4 3 2 -51 0 0 100
179656 8949760 626 4294967295 134512640 134632616 3221222544 3221221468
4294959106 0 0 4096 24579 3222428573 0 0 17 0 50 1 47 4 3 2


Comment 6 Alexander Larsson 2003-03-11 15:52:53 UTC
I see. The priority field is negative, and somewhere top is printing it as an
unsigned value.


Comment 7 Alexander Larsson 2003-03-11 15:53:48 UTC
*** Bug 85552 has been marked as a duplicate of this bug. ***

Comment 8 Alexander Larsson 2003-03-14 14:56:09 UTC
Fixed in procps 2.0.11-7. Will reach rawhide soon.



Note You need to log in before you can comment on or make changes to this bug.