Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 854210 - engine: log does not report which domain is not accessible when host becomes non-operational (because it cannot access a domain)
Summary: engine: log does not report which domain is not accessible when host becomes ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.1.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2012-09-04 11:27 UTC by Dafna Ron
Modified: 2016-02-10 20:11 UTC (History)
10 users (show)

Fixed In Version: vt1.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:
scohen: Triaged+


Attachments (Terms of Use)
log (deleted)
2012-09-04 11:27 UTC, Dafna Ron
no flags Details
logs (deleted)
2012-10-21 14:15 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29195 None None None Never

Description Dafna Ron 2012-09-04 11:27:35 UTC
Created attachment 609638 [details]
log

Description of problem:

when a host becomes non-operational because it cannot access a domain, even log reports the event without the domain name. 

Host gold-vdsd cannot access one of the Storage Domains attached to it, or the Data Center object. Setting Host state to Non-Operational.

Version-Release number of selected component (if applicable):

si16

How reproducible:

100%

Steps to Reproduce:
1. in a two hosts cluster block one of the domains in one of the hosts only
2.
3.
  
Actual results:

the following event is shown in the event log: 

Host gold-vdsd cannot access one of the Storage Domains attached to it, or the Data Center object. Setting Host state to Non-Operational.

Expected results:

we should specify the domain's name to allow better debugging by the user. 

Additional info:


backend log is not much help as well and a separate bug is opened for backend log

2012-09-04 12:48:12,219 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (QuartzScheduler_Worker-45) [4e183cd4] START, ConnectStorageServerVDSCommand(vdsId = 8c289d3a-f4d7-11e1-8cda-001a4a169741, storageP
oolId = f570527f-004a-4cab-8bee-129fa589bec5, storageType = ISCSI, connectionList = [{ id: bc1efcff-3f14-4502-9728-89fbc29e0100, connection: 10.35.64.10 };{ id: c5a034c9-db6e-4741-ac6e-b84495e7cc37, connection: 10.35.64.11 };{ id: ff668
0e9-2550-4a30-b947-1648617c62cc, connection: 10.35.160.7 };{ id: 6a41fd87-0726-43a3-9306-32fb3e241ed5, connection: 10.35.64.10 };{ id: bed3f09f-d7d4-4f8f-bcd6-e7f55df5be31, connection: 10.35.64.10 };]), log id: 3380e3f8
2012-09-04 12:48:13,390 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (QuartzScheduler_Worker-45) [4e183cd4] FINISH, ConnectStorageServerVDSCommand, return: {bc1efcff-3f14-4502-9728-89fbc29e0100=0, c5a
034c9-db6e-4741-ac6e-b84495e7cc37=0, ff6680e9-2550-4a30-b947-1648617c62cc=0, 6a41fd87-0726-43a3-9306-32fb3e241ed5=0, bed3f09f-d7d4-4f8f-bcd6-e7f55df5be31=465}, log id: 3380e3f8
2012-09-04 12:48:13,402 INFO  [org.ovirt.engine.core.bll.storage.ISCSIStorageHelper] (QuartzScheduler_Worker-45) [4e183cd4] The lun with id HXT9pz-3stk-TPSL-Irup-5P31-887A-3AZMHm was reported as problematic !
2012-09-04 12:48:13,436 ERROR [org.ovirt.engine.core.bll.storage.ISCSIStorageHelper] (QuartzScheduler_Worker-45) [4e183cd4] The connection with details 10.35.64.10 failed because of error code 465 and error message is: failed to setup i
scsi subsystem
2012-09-04 12:48:13,436 INFO  [org.ovirt.engine.core.bll.storage.ConnectHostToStoragePoolServersCommand] (QuartzScheduler_Worker-45) [4e183cd4] Host gold-vdsd storage connection was failed

Comment 1 Tal Nisan 2012-10-02 17:04:38 UTC
http://gerrit.ovirt.org/#/c/8306/

Comment 3 Allon Mureinik 2012-10-02 17:51:46 UTC
Merged change-id I18abfa25c762a19bb65f65d62b310fe22bea1aaf

Comment 4 Dafna Ron 2012-10-14 13:56:49 UTC
same error: 

Host gold-vdsd cannot access one of the Storage Domains attached to the Data Center TESTI. Setting Host state to Non-Operational.

Comment 5 Tal Nisan 2012-10-16 13:52:53 UTC
http://gerrit.ovirt.org/#/c/8605/

Comment 7 Tal Nisan 2012-10-16 17:19:57 UTC
Added a log entry before the one above which contains all the storage domains that had an error when connecting to

Comment 8 Allon Mureinik 2012-10-16 17:53:52 UTC
Merged Ib412608941f1223eb52bbde85ef7ece52c64ec0f

Comment 9 Dafna Ron 2012-10-21 14:15:03 UTC
tested in si21.1
when the storage domain is created from one lun than we see the following error: 

Storage Domain testi-01 (Data Center iSCSI) was deactivated by system because it's not visible by any of the hosts. 

but when the storage was created from two different luns which are on different storages we do not see the storage name or the problematic lun (no other entry)i: 

Host gold-vdsc cannot access one of the Storage Domains attached to the Data Center iSCSI. Setting Host state to Non-Operational.

moving back to devel

Comment 10 Dafna Ron 2012-10-21 14:15:41 UTC
Created attachment 630886 [details]
logs

Comment 11 Ayal Baron 2012-10-21 16:53:05 UTC
Dafna, what's the difference between this and bug 854214?

Comment 12 Dafna Ron 2012-10-21 17:24:24 UTC
these are two different flows. 

this one is for a problematic domain when all luns are invisible (I am testing with a domain with one lun on one server). 
in this case we would like to see the domain name (not just uuid) in event log. 

for bug 854214 its a problematic lun out of the domain.
so i am testing with a domain with 2 luns on 2 storage servers when only one lun is invisible.  
in this case we would like to see both the domain name and the problematic lun in event log.

Comment 13 Tal Nisan 2012-10-22 16:57:28 UTC
Please attach VDSM log too

Comment 14 Haim 2012-10-28 14:36:19 UTC
(In reply to comment #13)
> Please attach VDSM log too

why do you need vdsm log ? this is a backend issue.

Comment 15 Tal Nisan 2012-11-07 13:33:17 UTC
To determine the whole process and the error code sent from VDSM, the command which is called can be invoked from a lot of places, need to find the correct one

Comment 16 Tal Nisan 2012-11-21 16:38:33 UTC
http://gerrit.ovirt.org/#/c/9399/

Comment 19 Kevin Alon Goldblatt 2014-08-07 13:23:13 UTC
All events were correctly displayed regarding the specific storage domain

Comment 20 Allon Mureinik 2015-02-16 19:11:19 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 21 Allon Mureinik 2015-02-16 19:11:28 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.