Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85417 - GRUB not installed properly, resulting system fails to boot
Summary: GRUB not installed properly, resulting system fails to boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-01 15:46 UTC by Miloslav Trmac
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-30 02:30:06 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 2003-03-01 15:46:43 UTC
Description of problem:
Installer of Phoebe 8.0.94 doesn't install GRUB properly. This worked
fine in RHL 8.0 and all previous Phoebe releases and is 100% reproducible
for me.

Version-Release number of selected component (if applicable):
anaconda-8.0.94-5 (Phoebe 8.0.94)

My partitioning: single 20 GB drive
/dev/hda1: 6 GB FAT32 (windows 95)
/dev/hda2: 1 GB ext3 (/ of previous betas or previous install of 8.0.94)
/dev/hda3: 128 MB /boot of RHL 8.0
/dev/hda5: swap
/dev/hda6: 12 GB / of RHL 8.0
RHL 8.0 installed on hda{3,5,6}, GRUB in MBR.

Started RHL 8.0.94 install in text mode
Czech language (cs)
format /dev/hda3 as ext3, mount as /
Deselect all package groups, "select individual packages",
deselect all packages
Selected to install GRUB on /dev/hda2
Install finishes with no errors.

On next boot the GRUB from /dev/hda3 starts, I chose chainloading of /dev/hda2.
Result:
The chainloaded GRUB outputs:
        Loading stage2
At this point the computer either hangs, or repeats this message indefinitely
(on subsequent install attempts).

During installation, the following GRUB commands are output on VTs:
        root (hd0,1)
        install /boot/grub/stage1 d (hd0,1) /boot/grub/stage2 p 
(hd0,1)/boot/grub/grub.conf

After starting up rescue mode, chroot'ing, starting grub and repeating
these commands, boot still hangs.
OTOH, starting rescue mode, chroot'ing and executing
        /sbin/grub-install /dev/hda2
results in a booting system.
[FWIW, grub-install uses the 'setup', not 'install' GRUB command]


I have made a snapshot of /dev/hda2 bootsector and /boot before running
grub-install and after. The differences are as follows:
* boot sector:
  - byte 0x40 changed from 0x80 to 0xFF (boot drive from "hda" to "auto")
  - embedded block list of stage2 changed
* /boot/grub/stage2:
  - embedded block list changed (file offsets 0x1E8 ...0x1FC)
  - embedded config file name changed from "(hd0,1)/boot/grub/grub.conf"
    to "/boot/grub/grub.conf"
    [repeating the commands above with (hd0,1)/boot... changed to /boot
     did not fix it though].
I have no idea how to debug this further, in particular why the block
lists are different.

NOTE: I have also tried an GUI install selecting X11 and GNOME, the system
booted OK in this case.

Comment 1 Jeremy Katz 2003-05-16 20:33:43 UTC
setup uses install internally but does embedding of a stage1_5 instead of doing
just stage1 -> stage2.  I'll investigate some more.

Comment 2 Miloslav Trmac 2003-07-30 02:30:06 UTC
I can't reproduce this with RHL 9 or 9.0.93. Let's hope it has gone for good.


Note You need to log in before you can comment on or make changes to this bug.