Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85406 - Double submitting arrays using POST with forms
Summary: Double submitting arrays using POST with forms
Keywords:
Status: CLOSED DUPLICATE of bug 82967
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-01 09:22 UTC by Tom
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:03 UTC


Attachments (Terms of Use)

Description Tom 2003-03-01 09:22:09 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/4.0 
 
Description of problem: 
Array from html forms are twice submitted using POST method 
 
Version-Release number of selected component (if applicable): 
2.0.40-11 
Maybe the bug might be fixed in a newer version, but there is no newer rpm available... 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
 
submit a form with array, e.g. 
<form action=phpinfo.php method=post> 
<input name=test[] value=123> 
<input name=test[] value=456> 
 
 
 
Actual Results:  $_POST["test"] = array ( 
 
  [0] = 123 
  [1] = 456 
  [2] = 123 
  [3] = 456 
) 
 
Expected Results:  $_POST["test"] = array ( 
 
  [0] = 123 
  [1] = 456 
) 
 
Additional info:

Comment 1 Joe Orton 2003-06-19 10:39:02 UTC
This can be solved by removing the AddType directive for .php.

*** This bug has been marked as a duplicate of 82967 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.