Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85390 - python source rpm rebuild needs krb5-devel, which is not a dependancy
Summary: python source rpm rebuild needs krb5-devel, which is not a dependancy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-01 00:50 UTC by Paul Wouters
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-08 19:17:18 UTC


Attachments (Terms of Use)

Description Paul Wouters 2003-03-01 00:50:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Tries to built python from source rpm, failed on finding krb5.h.
I assume this is a missing dependancy.

Installing krb5-devel resolved this


(note. I selected phoebe on the previous page, this one only lets me
select 8.0)

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. on a system without krb5-devel installed, --rebuild python
2. satisfy all the -devel package dependancies and try again
3. compile fails on missing krb5.h
4. install krb5-devel
5. be happy :)
    

Additional info:

Comment 1 Mihai Ibanescu 2003-04-16 18:15:43 UTC
In Red Hat 9, openssl-devel (which is a prerequisite to build python) requires
krb5-devel, so adding krb5-devel would not gain anything. I tried to see if
python-2.2.2 builds without krb5-devel on 8.0 - and it does.

Looks like a NOTABUG to me (or NOTABUGANYMORE :-)

Comment 2 Mihai Ibanescu 2003-07-08 19:17:18 UTC
No response, closing. Feel free to reopen if the problem still exists.


Note You need to log in before you can comment on or make changes to this bug.