Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85363 - Traceback when neither CUPS nor LPRng installed
Summary: Traceback when neither CUPS nor LPRng installed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
: 101909 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-28 16:16 UTC by Miloslav Trmac
Modified: 2007-04-18 16:51 UTC (History)
2 users (show)

Fixed In Version: 0.6.72-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-29 16:03:39 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 2003-02-28 16:16:55 UTC
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47-1.i386.rpm

Steps to Reproduce:
1.Install redhat-config-printer without installing CUPS or LPRng
    
Actual results:
Traceback at /usr/share/printconf/util/cups_import.py line 195

Comment 1 Trond Eivind Glomsrød 2003-04-15 10:38:56 UTC
Here is a traceback from the released version, redhat-config-printer-0.6.47-1.
All you have to do is to not select printing while you do select configuration
tools during a custom install.


[root@dpc-21 mail]# Initializing alchemist edit environment ...
Initializing linux printing database ...
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 12, in ?
    printconf_tui.startup_and_find_cmd()
  File "/usr/share/printconf/util/printconf_tui.py", line 2343, in
startup_and_find_cmd
    main.cmd_handlers[cmd]()
  File "/usr/share/printconf/util/printconf_tui.py", line 1975, in tui_main_run
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
 


Comment 2 Bill Nottingham 2003-08-08 03:18:22 UTC
*** Bug 101909 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2003-08-08 08:04:20 UTC
redhat-config-printer should require cups.


Note You need to log in before you can comment on or make changes to this bug.