Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85355 - redhat-logviewer crashes on open
Summary: redhat-logviewer crashes on open
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-logviewer
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tammy Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-28 15:15 UTC by allan grossman
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-10 16:23:37 UTC


Attachments (Terms of Use)

Description allan grossman 2003-02-28 15:15:17 UTC
Description of problem:

redhat-logviewer crashes on open

Version-Release number of selected component (if applicable):

Default that ships with RH 8.0.


How reproducible:

Easy - just try to run the application.

Steps to Reproduce:
1.  Run redhat-logviewer
2.
3.
    
Actual results:

When run from terminal, application crashes with the following information:

unable to translate from iso-8859-1 utf-8
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 30, in ?
    import LogViewerGui
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 137, in ?
    ftpClass = LogFileClass.LogFileClass("FTPLOG")
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 69, in __init__
    self.read_log(self.prefName)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 119, in read_log
    self.buffer.insert_into_buffer_at_offset(iter, line)
  File "/usr/share/redhat-logviewer/LogBuffer.py", line 117, in 
insert_into_buffer_at_offset
    self.insert(iter, line, -1)
TypeError: GtkTextBuffer.insert() argument 2 must be string without null bytes,
not str


Expected results:

I expected to able to view logfiles.


Additional info:

Comment 1 Tammy Fox 2003-03-01 01:18:49 UTC
What is your $LANG environment variable set to? Can you read the FTP log file
with a text editor such as vi or Emacs? 

Comment 2 allan grossman 2003-03-01 12:04:58 UTC
$LANG is en_US.iso885915

I can read the FTP log in vi or gedit.

Comment 3 allan grossman 2003-03-01 23:49:35 UTC
Tammy, I'm going out of town on business first thing Sunday morning and will 
be without email all next week.  I'll be back in town the evening of March 8.

thanks!

Comment 4 Tammy Fox 2003-03-06 17:23:19 UTC
Is this system a fresh install of RHL 8.0 or an upgraded system? If it is an
upgraded system, please tell me what version was installed and which versions
it was upgraded to. AFAIK, none of our final versions set the locale to
en_US.iso885915. Have you upgraded it from a beta version? The default US English
locale for RHL 8.0 is en_US.UTF-8. I think your log file is encoded in
en_US.iso885915, which is why it can not be read properly by redhat-logviewer.

Comment 5 allan grossman 2003-03-08 23:07:19 UTC
This is an upgrade from RH7.3 - but httpd was downgraded back to Apache 1.3 as 
there are some issues with php and Apache 2.x.

I changed etc/sysconfig/i18n to UTF-8 and logviewer now works - thank you.

One more question.  Since this /i18n looks exactly like a RH7.3 version I 
don't know what the SYSFONT and SUSFONTACM variables should be set to.  I left 
iso885915 as a supported locale just in case - can you give me the defaults 
for the other two variables?

thanks again  :)

Comment 6 Tammy Fox 2003-03-10 16:23:37 UTC
FWIW, upgrades are not supposed to modify /etc/sysconfig/i18n. That is why your
values are still from RHL 7.3. On a RHL 8.0 box, the following is in
/etc/sysconfig/i18n:

LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"

I'm closing this as NOTABUG since it wasn't a bug in redhat-logviewer after all.


Note You need to log in before you can comment on or make changes to this bug.