Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85353 - Traceback if DISPLAY not set
Summary: Traceback if DISPLAY not set
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-packages
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-28 14:49 UTC by Miloslav Trmac
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-28 23:31:06 UTC


Attachments (Terms of Use)
Patch fixing the traceback and copying the code to other two toplevel files (deleted)
2003-02-28 15:43 UTC, Miloslav Trmac
no flags Details | Diff

Description Miloslav Trmac 2003-02-28 14:49:17 UTC
Description of problem:
/usr/share/redhat-config-packages/MainWindow.py contains code that's
supposed to exit nicely when gtk can't be imported. Unfortunately,
triggering this code results in traceback ;-)

Version-Release number of selected component (if applicable):
redhat-config-packages-1.1.6-1

Steps to Reproduce:
1. (unset DISPLAY; /usr/sbin/redhat-config-packages)

Additional info:
Maybe the other two exectuables (redhat-{cdinstall-helper,install-packages}
aka InstallDruid.py and SinglePackageWindow.py) should contains similar
checks.

Comment 1 Miloslav Trmac 2003-02-28 15:43:40 UTC
Created attachment 90423 [details]
Patch fixing the traceback and copying the code to other two toplevel files

This seems to solve the traceback issue for all three toplevel files.
"seems to" because I can test it only on RHL 7.3 right now.

Comment 2 Jeremy Katz 2003-07-28 23:31:06 UTC
Caught in CVS


Note You need to log in before you can comment on or make changes to this bug.