Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85345 - libIDL-config-2 gives wrong library name with --libs
Summary: libIDL-config-2 gives wrong library name with --libs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libIDL
Version: 1.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-28 13:05 UTC by Santtu Lakkala
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version: 0.8.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-03-03 21:12:44 UTC


Attachments (Terms of Use)

Description Santtu Lakkala 2003-02-28 13:05:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
libIDL-config-2 --libs gives -lIDL -lglib, of which libIDL.so doesn't exist in
-devel package and it really depends on glib2. pkg-config gives out the right
information, but i.e. mozilla uses libIDL-config (which again doesn't exist in
the package, since named libIDL-config-2) 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. libIDL-config-2 --libs


Actual Results:  -L/usr/lib -lIDL -lglib

Expected Results:  -lIDL-2 -lglib-2.0

Additional info:

Also, libIDL-config-2 --cflags gives -I/usr/include/glib-1.2
-I/usr/lib/glib/include while pkg-config libIDL-2.0 --cfalgs gives
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include

Comment 1 Mark McLoughlin 2004-03-03 21:12:44 UTC
This has been fixed for quite some time


Note You need to log in before you can comment on or make changes to this bug.