Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85342 - memory leak with .pcf.gz
Summary: memory leak with .pcf.gz
Keywords:
Status: CLOSED DUPLICATE of bug 85064
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: freetype
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-28 11:58 UTC by Mike A. Harris
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:02 UTC


Attachments (Terms of Use)
Freetype leak testcase (deleted)
2003-02-28 12:02 UTC, Mike A. Harris
no flags Details
Bugfix patch from freetype development mailing list. (deleted)
2003-02-28 12:03 UTC, Mike A. Harris
no flags Details | Diff

Description Mike A. Harris 2003-02-28 11:58:36 UTC
Date: 24 Feb 2003 23:52:07 +0100
From: Pixel <pixel@mandrakesoft.com>
To: devel@freetype.org
Cc: Frederic Crozat <fcrozat@mandrakesoft.com>
Content-Type: multipart/mixed; boundary="=-=-="
List-Id: Bugs, Wish Lists, Features, Development, etc.. <devel.freetype.org>
Subject: [Devel] patch to fix memory leak with .pcf.gz files
 
Problem encountered with "fc-cache -f" using more than 100MB of memory
when scanning /usr/lib/X11/fonts/75dpi + /usr/lib/X11/fonts/100dpi
 
ft-test-leak.c shows the problem (needs a .pcf.gz font) when setting
FT_DEBUG_MEMORY:
 
> FreeType.Debug: FreeType: 44376 bytes of memory leaked in 4 blocks
 
Simple fix included (i'm no zlib nor freetype guru, but it seems the
right thing to do :)

Comment 1 Mike A. Harris 2003-02-28 12:02:35 UTC
Created attachment 90409 [details]
Freetype leak testcase

Comment 2 Mike A. Harris 2003-02-28 12:03:31 UTC
Created attachment 90410 [details]
Bugfix patch from freetype development mailing list.

Comment 3 Mike A. Harris 2003-02-28 12:05:22 UTC
I haven't verified this bug nor tested the patch.  I just spotted it on
the mailing list and thought I should bugzilla it so we can test for the
problem and fix our package if it is applicable.

Comment 4 Owen Taylor 2003-02-28 15:00:07 UTC
I've already verified the leak, verified the fix, and checked
a patch into package CVS :-)
 

*** This bug has been marked as a duplicate of 85064 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:52:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.