Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85323 - Installer fails to detect/configure Dell E171FP Flat Panel display
Summary: Installer fails to detect/configure Dell E171FP Flat Panel display
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
: 85325 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-28 00:02 UTC by Dave W.
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-04 14:01:52 UTC


Attachments (Terms of Use)

Description Dave W. 2003-02-28 00:02:10 UTC
Description of problem: Red Hat 8.0 Installer fails to correctly identify and
configure a Dell E171FP Flat Panel display.


Version-Release number of selected component (if applicable): 8.0


How reproducible: Every time.


Steps to Reproduce:
1. Try installing RH 8.0 from CDs on a PC with this monitor attached.
    
Actual results: Monitor displays a black screen with the words "Cannot display
this video mode."


Expected results: Graphical installer should work. Settings specified during
installation should work once RH is installed.


Additional info: Finally got RH installed by starting installer with "linux
resolution=1280x1024 skipddc", rebooting (gives same black screen and error),
killing gdm, and then manually editing /etc/X11/XF86Config to add appropriate
modelines. Used the procedure described at
<http://www.xmission.com/~howardm/modelines.html> to calculate the entries. The
installer does list the Dell E151p (a smaller predecessor?) among its known
displays, but that did not work.

FWIW, the redhat-config-xfree86 utility does not work either -- after choosing
appropriate resolution, etc., under the Advanced section and restarting X, the
same error message appears.

Specs are at <http://support.ap.dell.com/docs/monitors/e171fp/en/specs.htm>.
This is a fairly new, VBE/DDC compatible display. Build date is December 2002.

I can post the output log(s) of ddcprobe,read-edid, XFree86 -configure, and
startx, and/or the appropriate .INF files (it is a dual-boot machine with WinXP)
if necessary.

Comment 1 Dave W. 2003-02-28 01:26:25 UTC
*** Bug 85325 has been marked as a duplicate of this bug. ***

Comment 2 Michael Fulbright 2003-03-04 17:51:20 UTC
This is a issue with either rhpl or kudzu.

Comment 3 Jeremy Katz 2003-03-04 17:54:48 UTC
What is the output of running /usr/sbin/ddcprobe on the installed system?

Comment 4 Dave W. 2003-03-06 18:48:36 UTC
Sorry for the delay... here are the results of running
/usr/sbin/ddcprobe:

| Videocard DDC probe results
|
| Description: Intel Corporation Brookdale-G Graphics Controller
| 
| Memory (MB): 7
|
| Monitor DDC probe results
| ID: DEL300f
| Name: DELL E171FP
| Horizontal Sync (kHZ): 30-80
| Vertical Sync (HZ): 56-76
| Width (mm): 340
| Height (mm): 270

From the monitor's specifications (see URL in comment #1 above),
the scan rates and screen dimensions are correct. I know the video
card has 64MB onboard, but I'm assuming the 7MB memory reported is
for the monitor, not the card.

Comment 5 Jeremy Katz 2003-07-28 23:30:07 UTC
Is this better with Red Hat Linux 9?

Comment 6 SM 2003-08-08 21:21:32 UTC
Unfortunately I no longer have access to this particular display. I installed
RH8 on a friend's new machine, which came with this monitor. If I can arrange to
borrow his display for a day, I will try to find a spare machine and install RH9
on it.


Note You need to log in before you can comment on or make changes to this bug.