Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85287 - up2date -u fails completely
Summary: up2date -u fails completely
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
: 91973 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-27 14:42 UTC by Paul Schmehl
Modified: 2007-04-18 16:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 20:10:10 UTC


Attachments (Terms of Use)

Description Paul Schmehl 2003-02-27 14:42:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20021120
Netscape/7.01

Description of problem:
up2date -u fails to run and produces the following error report:

 sudo up2date -u
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 934, in ?
    main()
  File "/usr/sbin/up2date", line 666, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 835, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 57, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 88, in
__findPackagesToUpdate
    plist.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 89, in run
    self.addObsoletePackages(obsList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 141, in
addObsoletePackages
    for p in obsoletePackages:
TypeError: iteration over non-sequence

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.sudo up2date -u
2.
3.
    

Actual Results:  The error message pasted in the Description field is
consistently produced every time up2date is run

Expected Results:  It should have gone to the RH site, determined what RPMs
needed to be updated, downloaded them and installed them.

Additional info:

The GUI updater fails as well, but it doesn't produce any error messages.  It
just sits there forever doing nothing.

Comment 1 Paul Schmehl 2003-02-27 14:49:02 UTC
Version of up2date is 3.0.42

Comment 2 Paul Schmehl 2003-02-27 15:33:51 UTC
When I tried to get the version of up2date, I got the following errors:

 up2date --version
 
(up2date:1389): Gtk-WARNING **: /usr/lib/gtk-2.0/2.2.0/engines/libredmond95.so:
undefined symbol: gtk_rc_style_get_type
 
(up2date:1389): GLib-GObject-CRITICAL **: file gobject.c: line 1315
(g_object_unref): assertion `G_IS_OBJECT (object)' failed

Comment 3 Adrian Likins 2003-03-04 16:08:12 UTC
3.0.42 is pretty old.

Do newer versions from later betas show the same problem?

Comment 4 Paul Schmehl 2003-03-04 16:42:08 UTC
I wasn't aware there was a newer one.  I fetched and installed 3.1.17-1 just now
and then tried to run it:

Gtk-WARNING **: /usr/lib/gtk-2.0/2.2.0/engines/libredmond95.so: undefined
symbol: gtk_rc_style_get_type
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 992, in ?
    main()
  File "/usr/sbin/up2date", line 719, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 892, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 57, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 88, in
__findPackagesToUpdate
    plist.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 88, in run
    self.addObsoletePackages(obsList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 116, in
addObsoletePackages
    for p in obsoletePackages:
TypeError: iteration over non-sequence

Because of the library error, I ran ldconfig and then tried to run up2date -u again:

[root@utd49554 root]# ldconfig
[root@utd49554 root]# up2date -u
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 992, in ?
    main()
  File "/usr/sbin/up2date", line 719, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 892, in batchRun
    batch.run()
  File "up2dateBatch.py", line 57, in run
  File "up2dateBatch.py", line 88, in __findPackagesToUpdate
  File "packageList.py", line 88, in run
  File "packageList.py", line 116, in addObsoletePackages
TypeError: iteration over non-sequence

Comment 5 Adrian Likins 2004-08-20 20:10:10 UTC
The problem here is the server is not subscribed to a base
channel. Please go the to rhn website and assign the server
to a channel 

Also, currently versions report a more useful error in this case.

Comment 6 Adrian Likins 2004-08-20 20:47:08 UTC
*** Bug 91973 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.