Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85284 - Problems with UTF-8 in mc-4.6.0 (in virtual consoles)
Summary: Problems with UTF-8 in mc-4.6.0 (in virtual consoles)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Jay Turner
URL:
Whiteboard: triage|leonardjo|closed|errata
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-27 14:14 UTC by Roman Szarowski
Modified: 2015-01-08 00:03 UTC (History)
5 users (show)

Fixed In Version: 4.6.0-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-26 16:35:02 UTC


Attachments (Terms of Use)

Description Roman Szarowski 2003-02-27 14:14:54 UTC
Description of problem:
When I upgraded from phoebe to phoebe-3, I noticed that release version of mc-4.6.0
has probably problems with frames and browsing through dir. structures in
virtual consoles
(due to UTF-8 as I expected). As soon as I downgraded to mc-4.6.0-pre1,
the problem disappeared.

Version-Release number of selected component (if applicable):
mc-4.6.0

How reproducible:


Steps to Reproduce:
1. Upgrade from redhat 8.0.93 to 8.0.94
2. launch mc in a virtual console
3.
    
Actual results:
Problems with UTF-8 charset.

Expected results:
To customize mc-4.6.0 to be able to display results in the same way as
mc-4.6.0-pre1 does.

Additional info:

Comment 1 Miloslav Trmac 2003-02-27 18:07:50 UTC
Reportedly this is fixe4d in mc-4.6.0-3 and slang-1.4.5-15
at ftp://people.redhat.com/jakub/mc/ .

I haven't checked yet though.




Comment 2 Peter van Egdom 2003-03-01 18:20:07 UTC
I installed both "slang-1.4.5-15" and "mc-4.6.0-3".

For me this version reintroduces the bug where Midnight Commander hangs (with
eating away CPU time) at displaying the 'Info' panel (F9 -> 'left' -> 'Info').

This bug was fixed for me in "mc-4.6.0-1".

Comment 3 Roman Szarowski 2003-03-02 14:00:05 UTC
I installed only "mc-4.6.0-3" (and leave slang-1.4.5-14)
and mc seems to work correctly (including correctly displayed panels).

Comment 4 Leonard den Ottolander 2004-10-26 16:35:02 UTC
Wrt comment 2: Please file a separate bug if the problem persists.

Wrt comment 3: If this issue is fixed this report can be closed.



Note You need to log in before you can comment on or make changes to this bug.