Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85245 - autorun dialog obscured by nautilus window
Summary: autorun dialog obscured by nautilus window
Keywords:
Status: CLOSED DUPLICATE of bug 106192
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: magicdev
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-26 22:05 UTC by Owen Taylor
Modified: 2007-04-18 16:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:00 UTC


Attachments (Terms of Use)

Description Owen Taylor 2003-02-26 22:05:54 UTC
Depending on timing, it's quite likely that when you stick 
in a CD with an autorun script you get:

 "Do you want to autorun" dialog on bottom
 Nautilus window for CD on top

I don't have a good idea about how to fix this other than
maybe sleep(5) && gdk_window_raise(dialog).

THe right behavior is perhaps that the nautilus window
doesn't open until you click No in the dialog.

But I don't have a clue about how to implement that, at
least without reintroducing magicdev <=> nautilus IPC.

Comment 1 Bastien Nocera 2003-12-15 00:14:45 UTC
This is not an issue anymore, as auto-opening new windows has been
removed from Nautilus, and magicdev upstream.
See the dup.

*** This bug has been marked as a duplicate of 106192 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.