Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85220 - Traceback when run from virtual console or xterm via "setup"
Summary: Traceback when run from virtual console or xterm via "setup"
Keywords:
Status: CLOSED DUPLICATE of bug 90185
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-26 19:05 UTC by Peter van Egdom
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:00 UTC


Attachments (Terms of Use)
Patch to seperate zonetab functionality from timezone map (deleted)
2003-05-20 00:39 UTC, James Olin Oden
no flags Details | Diff
Console patch that does not break gui tool (-; (deleted)
2003-05-20 19:29 UTC, James Olin Oden
no flags Details | Diff

Description Peter van Egdom 2003-02-26 19:05:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Running the Text Mode Setup Utility ("setup") from either a xterm or a virtual
console, and selecting "Timezone configuration", results in an error.

If you do this on a virtual console, the error quickly flashes away and the main
menu of the Text Mode Setup Utility is redrawn.

If you do this inside an xterm in a X session, the error is visible on the
commandline :

Traceback (most recent call last):
  File "/usr/share/redhat-config-date/timeconfig.py", line 29, in ?
    from timezone_map_gui import ZoneTab
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 18, in ?
    import gtk
  File
"/usr/src/build/218821-i386/install/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.py",
line 43, in ?
RuntimeError: could not open display
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

This can be resolved by entering "xhost +" before starting this, this makes the
Timezone Configuration part of setuptool work properly inside an xterm.

However, on a virtual console this does not work (ofcourse). But for text mode
only installs the Timezone Configuration should always work inside a virtual
console.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (on a virtual console) "# setup" -> Timezone Configuration.
2. (inside a xterm) "# setup" -> Timezone Configuration.
3. 
    

Actual Results: 
(on a virtual console) -> screen flashes -> error not readable -> returns to
main menu


(inside a xterm) -> traceback ->

Traceback (most recent call last):
  File "/usr/share/redhat-config-date/timeconfig.py", line 29, in ?
    from timezone_map_gui import ZoneTab
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 18, in ?
    import gtk
  File
"/usr/src/build/218821-i386/install/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.py",
line 43, in ?
RuntimeError: could not open display
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified



Expected Results: 
- The Timezone Configuration should work both in text mode on a virtual console
and in X inside a X terminal.

- "xhost +" should not be a requirement for running this tool in X.

Additional info:

Tried the following versions on a fresh Phoebe 8.0.94 installation :

Phoebe 8.0.94 -> setuptool-1.11-1.src.rpm
Rawhide       -> setuptool-1.12-1.src.rpm

Phoebe 8.0.94 -> redhat-config-date-1.5.9-6
Rawhide       -> redhat-config-date-1.5.9-7

Comment 1 James Olin Oden 2003-05-20 00:39:55 UTC
Created attachment 91807 [details]
Patch to seperate zonetab functionality from timezone map

The base problem was the timeconfig.py needed the zonetab but it did
not need the gtk baggage along with it.

Comment 2 James Olin Oden 2003-05-20 19:29:31 UTC
Created attachment 91839 [details]
Console patch that does not break gui tool (-;

Basically the same patch, but I managed to break the gui tool with the
other one.

Comment 3 Brent Fox 2003-05-23 16:51:30 UTC
Doh!  I looked at bug #90185 before I looked at this one and wound up implenting
your patch almost verbatim!  Great minds must think alike.  :)  I should have
looked at this report first.  

At any rate, redhat-config-date-1.5.10-1 should fix the problem and should
appear in Rawhide soon.  

Thanks for the work on the patch...I'm sorry I didn't see it earlier.

*** This bug has been marked as a duplicate of 90185 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.