Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85203 - iptables rules saved to /etc/sysconfig/iptables do not restore on startup
Summary: iptables rules saved to /etc/sysconfig/iptables do not restore on startup
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-26 16:57 UTC by Ajoy Chundee
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-28 11:33:56 UTC


Attachments (Terms of Use)

Description Ajoy Chundee 2003-02-26 16:57:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Hi All,

Rules are created and stored in /etc/sysconfig/iptables without problems.

When the system is started up these rules do not restore.  A set of "blanket" 
rules are applied.  However if i execute "/sbin/service iptables restart", the 
rules that I have created load correctly.

Thanks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create custom IPTABLES rules after flushing current rules.
2. use iptables-save  > /etc/sysconfig/iptables
3. restart the system
4. use iptables -L and the ruleset created does not appear, standard rules 
appear
5. use /sbin/service restart iptables
6. use iptables -L and the correct rules appear.
    

Additional info:

Comment 1 Michael Schwendt 2003-02-26 21:21:52 UTC
You can close this report because it is not a bug.

The correct procedure is to enable service "iptables" with running "chkconfig
iptables on". That will enable the script for current run-level.


Comment 2 Ajoy Chundee 2003-02-26 22:19:14 UTC
So which runlevel should I be assigning iptables to please?

Thanks.

Comment 3 Michael Schwendt 2003-02-27 15:18:04 UTC
The one you use and all run-levels that should enable the iptables rules.

Look into redhat-config-services or consult "man chkconfig" for more information. 

Please move further discussion to a mailing-list.



Note You need to log in before you can comment on or make changes to this bug.