Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85150 - KAsteroids displays with an untitiled window
Summary: KAsteroids displays with an untitiled window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-desktop
Version: 6.1.90
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
: 100649 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-02-26 01:45 UTC by Eugenia Loli-Queru
Modified: 2007-04-18 16:51 UTC (History)
3 users (show)

Fixed In Version: 2.3.6.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-03-03 21:05:44 UTC


Attachments (Terms of Use)
Patch to fix KDE app launching from gnome (deleted)
2003-07-29 22:09 UTC, George Lebl
no flags Details | Diff

Description Eugenia Loli-Queru 2003-02-26 01:45:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0

Description of problem:
Running Kasteroids from within Gnome, Metacity displays the window with no title
caption.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch Kasteroids via Gnome's games menu.

Actual Results:  No title caption in the Metacity window manager for this window.

Expected Results:  Having a title caption..

Additional info:

Bluecurve on 1600x1200x24 bit color here, IF that matters...

Comment 1 James Mitchell Ullman 2003-02-27 02:01:44 UTC
Kenolaba has the same problem.

Comment 2 Ngo Than 2003-02-27 22:18:41 UTC
It seems that Exec=kasteroids %i %m -caption "%c" is not correct handled from
gnome-panel

Comment 3 Eugenia Loli-Queru 2003-07-25 20:42:39 UTC
The problem still exists on Severn and it is even worse than on RHL9. 90% of 
all the KDE apps launched from the Gnome memu don't have a Title in the window 
manager.

Comment 4 Havoc Pennington 2003-07-28 00:21:50 UTC
George maybe you could look at this?

Comment 5 George Lebl 2003-07-28 17:12:09 UTC
This is not a bug in the panel but either in the .desktop files or in the spec.
 If you look at
http://www.freedesktop.org/standards/desktop-entry-spec/0.9.4-onehtml/

Then the %c is meant to expand to the Comment field, however the relevant
.desktop files have no comment field.  I suspect KDE is then breaking the spec
here.  Since the spec contains this stuff because of KDE however mostly I
suppose we should fix the spec.  I'm mailing xdg-list.

Note that there is more broken in the % expansion then meets the eye.  %m is not
in the spec and explicitly disallowed, %i seems to expand in KDE to something
like two arguments "-icon foo", and %k has very vague description of what it is
(I assumed the name of the desktop file)

Comment 6 George Lebl 2003-07-29 22:09:08 UTC
Created attachment 93237 [details]
Patch to fix KDE app launching from gnome

The spec is very vague, and KDE breaks the spec in several places.  This patch
is what I commited on HEAD and should apply to stable as well since nothing
changed here lately.  Basically it will do things the way KDE does things and I
suppose we should put that in the spec.  Mailed xdg-list about this already.

Comment 7 George Lebl 2003-07-29 22:11:24 UTC
Note the patch is for gnome-desktop, not gnome-panel, I forgot to mention that

Comment 8 Havoc Pennington 2003-07-30 14:30:24 UTC
*** Bug 100649 has been marked as a duplicate of this bug. ***

Comment 9 Mark McLoughlin 2004-03-03 21:05:44 UTC
Seems to be working fine in Raw Hide and should have been working
correctly in Fedora Core 1 also.


Note You need to log in before you can comment on or make changes to this bug.