Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85128 - install time root password dialog rejects space characters in passwd
Summary: install time root password dialog rejects space characters in passwd
Keywords:
Status: CLOSED DUPLICATE of bug 84705
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 22:59 UTC by David Wilson
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:59 UTC


Attachments (Terms of Use)

Description David Wilson 2003-02-25 22:59:48 UTC
Description of problem:
When entering the root password during an install, a space character is 
rejected as "not being an ascii character".

Version-Release number of selected component (if applicable):
phoebe-3

How reproducible:
always

Steps to Reproduce:
1. Try entering a password containing a space
2.
3.
    
Actual results:
error message about password containing a non-ascii character

Expected results:

password would be accepted

Additional info:

Last time I looked ASCII (not ascii) characters went from 00 (nul) to 7f (del).
You probably do not want people using control characters but I cannot see any 
reason to forbid a space character. The error message text is wrong and the 
code that tests for invalid characters is to restrictive.

Comment 1 Jeremy Katz 2003-02-25 23:09:46 UTC

*** This bug has been marked as a duplicate of 84705 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.