Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85117 - syslog gets polluted with "SIGCHLD set to SIG_IGN but calls wait()"
Summary: syslog gets polluted with "SIGCHLD set to SIG_IGN but calls wait()"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: utempter
Version: phoebe
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 21:42 UTC by Peter van Egdom
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-25 22:31:42 UTC


Attachments (Terms of Use)

Description Peter van Egdom 2003-02-25 21:42:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Since Phoebe 3 (Phoebe 8.0.94), the kernel introduces a mention of an
application bug, triggered by programs like "xterm" and parts of Anaconda :

 "application bug: xterm(7260) has SIGCHLD set to SIG_IGN but calls
  wait().
  (see the NOTES section of 'man 2 wait'). Workaround activated."



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Start "xterm"
2. Type something inside xterm.
3. "dmesg"
    

Actual Results:   

"application bug: xterm(7260) has SIGCHLD set to SIG_IGN but calls
 wait().
 (see the NOTES section of 'man 2 wait'). Workaround activated."


Expected Results:  No application bug.

Additional info:

kernel-2.4.20-2.48
glibc-2.3.1-46
Phoebe 8.0.94

Comment 1 Arjan van de Ven 2003-02-25 21:48:52 UTC
that's the app being buggy... not the kernel.
but please make sure you've updated phoebe to other parts too, eg utemper etc

Comment 2 Peter van Egdom 2003-02-25 22:31:42 UTC
Hmm.. okay, updated to "utempter-0.5.2-16" fixes described problem.
Reassigning component from 'kernel' to 'utempter' and closing bug.
Thanks!



Note You need to log in before you can comment on or make changes to this bug.