Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85115 - Unable to use "supplemental driver disk" during installation
Summary: Unable to use "supplemental driver disk" during installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 21:32 UTC by Daniele
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-23 01:54:56 UTC


Attachments (Terms of Use)

Description Daniele 2003-02-25 21:32:26 UTC
Description of problem:

Hi,

I'm trying to install Redhat 8 linux on my raid array. I'm using the Promise "MB FastTrack 133 lite" onboard ide raid controller, on my asus p4t533. 

The current version of linux kernel doesn't support this drivers yet. So I downloaded the linux drivers from the Promise website (www.promise.it) in order to make a "supplemental driver disk" to use during installation phase. The drivers are for RedHat 7.x.

I made the supplemental driver disk and it works well with Redhat 7.2. 

I tried with Redhat 8. Anaconda ask me if I have drivers disk so I reply "yes". It ask for the driver. I press Ok and it load something. After the media check Anaconda ask me for supplemental driver disk another time. I press Ok and I obtain the message "Impossible to mount: device is busy" or similar message. It' possible that the message come because the floppy is already mounted and anaconda did not umount it? In this case is possible to open during installation a shell to manually umount the floppy?

At the moment I cannot install Redhat 8 on my system for this problem...

I checked the cd (downloaded from our mirrors) and they are ok.

My system configuration is:

Pentium IV 2.4 GHz
Main board Asus P4T533 Raid
Memory 2x256 Mb RIMM @ 1066 MHz
Graphic card 3d prophet (nVidia GeForce 3 Ti200)
2 hd maxtor 60 Gb in raid array (stripe mode) on "MB FastTrack 133 lite" promise controller
Controller scsi Acard 6712UW. On the scsi chain dvd player and cd burner.
Sound card Audigy2 Platinum

Thanks in advance,
Daniele.



How reproducible:

Every time


Steps to Reproduce:
1. Insert first cd of RedHat 8 in order to install it.
2. Make a "supplemental driver disk", in particular with "TX2000" drivers from www.promise.com
3. Try to use the supplemental driver disk

    
Actual results:

It's impossible to use supplemental driver disk. "Device (floppy) is busy"
Unable to use the supplemental disk drivers during installation

Expected results:


Additional info:

Comment 1 Michael Fulbright 2003-02-26 16:16:06 UTC
This storage controller is not officially supported by Red Hat.

Have you contacted Promise about installation support with this controller?

Comment 2 Daniele 2003-02-27 10:57:23 UTC
If the problem is in floppy mount/umount, is it possible to open during 
anaconda a shell in order to manually umount the floppy?

Daniele.

Comment 3 Daniele 2003-02-27 11:15:04 UTC
I think *this* problem isn't in controller. 

If the problem is in controller driver anaconda should load it and then 
say "the controller doesn't run" or similar message. The error message 
is "Impossible to mount: device is busy" when tries to access to floppy: 
anaconda doesn't load nothing from floppy!". And if I press "retry" I've the 
same message, I have to press "ignore", so aborting the installation of 
supplemental device driver.......

Daniele.

Comment 4 Jeremy Katz 2003-04-23 01:54:56 UTC
This should be fixed in our current release.


Note You need to log in before you can comment on or make changes to this bug.