Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85106 - G400 DRI leaks 12 megs kernel memory each time X starts
Summary: G400 DRI leaks 12 megs kernel memory each time X starts
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
: 82896 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-25 19:17 UTC by Alexander Larsson
Modified: 2016-03-27 14:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-28 02:49:20 UTC


Attachments (Terms of Use)
XFree86 log (deleted)
2003-02-25 19:19 UTC, Alexander Larsson
no flags Details
/proc/pci (deleted)
2003-02-25 19:21 UTC, Alexander Larsson
no flags Details
/var/log/messages (deleted)
2003-02-25 19:46 UTC, Alexander Larsson
no flags Details

Description Alexander Larsson 2003-02-25 19:17:38 UTC
Every time I start and exit X the sum of "Active + Inact_dirty + Inact_laundry +
Inact_clean + MemFree" in /proc/meminfo drops by about 12 megs.

kernel is: 2.4.20-2.50
XFree86 is: 4.2.00.901-20030212.0

Comment 1 Alexander Larsson 2003-02-25 19:19:41 UTC
Created attachment 90359 [details]
XFree86 log

Comment 2 Alexander Larsson 2003-02-25 19:21:19 UTC
Created attachment 90360 [details]
/proc/pci

Comment 3 Alexander Larsson 2003-02-25 19:22:06 UTC
Commenting out Load "DRI" in XF86Config removes the leak.


Comment 4 Mike A. Harris 2003-02-25 19:28:57 UTC
attach /var/log/messages too to peekaboo at agpgart loading et al.

Comment 5 Alexander Larsson 2003-02-25 19:46:50 UTC
Created attachment 90361 [details]
/var/log/messages

Comment 6 Alexander Larsson 2003-02-27 14:18:52 UTC
This also happens on at least i8x0 cards.
This is not nptl related, but seems rmap related.
Arjans kernel-2.4.20-5nonptlfixrmap build fixes it. Waiting on an NPTL enabled
build to test that.


Comment 7 Bill Nottingham 2003-02-27 17:15:50 UTC
Should be fixed in -6.

Comment 8 Jay Turner 2003-02-28 02:49:20 UTC
Fix confirmed with the latest kernel.

Comment 9 Mike A. Harris 2003-02-28 07:50:38 UTC
Just to clarify with a bit more detail for those who might find this bug
report when doing a bugzilla query, this problem was due to a refcount
bug in rmap with respect to PageReserved pages. DRM marks it's pages as
PageReserved and was affected by this bug. (In Arjan's words)

Problem fixed in kernel-2.4.20-6 by Arjan The Machine(TM)  ;o)

Comment 10 vvs 2003-04-01 05:16:49 UTC
*** Bug 82896 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.