Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85102 - Memory leak using VNC
Summary: Memory leak using VNC
Keywords:
Status: CLOSED DUPLICATE of bug 80414
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vnc
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 18:33 UTC by Peter van Egdom
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:58 UTC


Attachments (Terms of Use)

Description Peter van Egdom 2003-02-25 18:33:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
I was experimenting with VNC using the "Remote Desktop Connection" tool
(Internet -> More internet applications -> Remote Desktop Connection") from a
KDE session.

After connecting to my 'localhost:1' VNC session, I was presented with the GNOME
desktop interface inside the VNC client on my screen.

I then started a gnome-terminal session from the GNOME menu inside my VNC
client. After I had done this my system began eating memory very fast; on
virtual console 1 I had a "vmstat 1" command running which went up to 700+ MB
swapfile usage. If I had not killed the Xvnc process my machine probably would
have crashed or would have become so unresponsive I had to reset.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
(reproduced twice).

01. Start a KDE session from GDM.
02. Open "konsole"
03. "su -"
04. "vncserver"
05. Internet ->More internet applications ->Remote Desktop Connection. 
06. Connect to localhost:1 
07. (VNC client starts presenting a GNOME desktop).
08. Start a Gnome-terminal session.
09. (window of Gnome-terminal gets drawn, but no fonts inside it).
10. (Xvnc starts eating memory very fast).

Actual Results: 
 Xvnc starts eating memory very fast and system quickly becomes unresponsive.

Expected Results: 
 No memory leaks should occur.

Additional info:

vnc-3.3.3r2-47
Red Hat Linux release 8.0.94 (Phoebe)

Comment 1 Tim Waugh 2003-02-25 18:39:45 UTC

*** This bug has been marked as a duplicate of 80414 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.