Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85099 - Unable to define serial printer correctly using printconf
Summary: Unable to define serial printer correctly using printconf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer
Version: 9
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 18:10 UTC by Pat Lawrence
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-07 16:36:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:125 normal SHIPPED_LIVE New redhat-config-printer packages available 2003-07-07 04:00:00 UTC

Description Pat Lawrence 2003-02-25 18:10:10 UTC
Description of problem:
Can't define serial printer in printconf.
Attempted to define a new serial printer (same in printconf-gui and printconf-
tui):
Local Printer
     Custom Device: /dev/ttyR7
     Epson 9-pin 80 column (omni driver is only choice)
Note that /dev/ttyR7 is a serial port on a Comtrol Rocketport card that does 
work for a serial terminal, and, once /etc/cups/printers.conf is edited, for 
printing.
I expect I would see the same behavior for /dev/ttyS0 or /dev/ttyS1, since 
there is no option to select either of these ports in printconf, either.
When you look in /etc/cups/printers.conf at the definition lines for the 
printer just created, you see:
DeviceURI file:/dev/ttyR7
and, with this line, if you try to print to the attached serial printer, you 
get some printing sometimes, ususally with lots of garbage characters.
If you edit the line so it looks like:
DeviceURI serial:/dev/ttyR7
you are able to print to the printer without problems.


Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.35-1
[root@award3 phl]# cat /etc/redhat-release
Red Hat Linux release 8.0.93 (Phoebe)
[root@award3 phl]# uname -m
i686

How reproducible:
always

Steps to Reproduce:
1.Define a serial printer using a custom device and a working serial port.
2.Attempt to print (get garbage or job queued but no printing).
3.Edit /etc/cups/printers.conf for the printer you created; change the 
word 'file' to the word 'serial' and the printer will work.

    
Actual results:
Got garbage attempting to print after defining the printer.

Expected results:
Should have gotten a normal printout.

Additional info:

Comment 1 Tim Waugh 2003-02-26 00:33:49 UTC
I think /dev/ttyS* should be okay; the serial: scheme was chosen if the device
name began '/dev/ttyS'.  I changed the test to "begins '/dev/tty'".

Fixed in CVS.

Comment 2 Tim Waugh 2003-07-07 16:36:33 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-125.html



Note You need to log in before you can comment on or make changes to this bug.