Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85088 - Install failure with Anaconda / RPM - reports error InstallCallback instance has no attribute 'beenCalled'
Summary: Install failure with Anaconda / RPM - reports error InstallCallback instance ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 16:42 UTC by Need Real Name
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-26 16:32:48 UTC


Attachments (Terms of Use)
Dump from crashed Anaconda (deleted)
2003-02-25 16:44 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-02-25 16:42:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Redhat 8.0 installer crashed during install, asked for bug to be reported.  
Ever subserviant to the machine, I obey.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Not reproduced.  But RH8.0 install still crashes on my computer at various 
stages. 
2.
3.
    

Additional info:

Comment 1 Need Real Name 2003-02-25 16:44:43 UTC
Created attachment 90354 [details]
Dump from crashed Anaconda

Comment 2 Michael Fulbright 2003-02-25 20:01:19 UTC
Have you tested your install media?

Comment 3 Need Real Name 2003-02-26 15:35:26 UTC
Yup, CDs 1 to 3 tested at begining of install.  All passed, but I'm getting 
hold of a new set of RH disks to retest.  This error has not reoccured, but 
install still not succesful, at this point, all attempts progress for a while 
and I am eventually greeted by something like package XXXX not found and reboot.

Is it possible that my CDs (burnt from image) are damaged/corrupted even if 
they pass the media test?

STOP PRESS... as I was typing this e-mail, I finally succeded in reinstalling 
RH8.0 (graphical interface; install ALL packages).  After tons of crazy 
attempts (including attempting to install a new BIOS and having to reinstall 
the original BIOS) it worked.  The only thing I can think of which was 
different with the succesful install was that I changed a BIOS setting "Primary 
Graphics Adapter" from PCI to AGP (my card is an AGP card).  As I said, I never 
reproduced the bug reported here, so the two events may be unconnected.

I have no idea if this is what made the install work, or simply if I was lucky 
and the CD were read properly on that run, but if it ain't broke, don't fix it!


Comment 4 Jeremy Katz 2003-02-26 16:32:48 UTC
Probably just weirdo cd read problems.  We continue to improve the handling of
those cases for every release.


Note You need to log in before you can comment on or make changes to this bug.