Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85080 - Oracle TNS-listener hang
Summary: Oracle TNS-listener hang
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel
Version: 2.1
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Larry Woodman
QA Contact: Brian Brock
URL:
Whiteboard:
: 85081 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 14:11 UTC by Boris Mironov
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-23 18:17:53 UTC


Attachments (Terms of Use)
Logs from 'crash' utility about status of 'tnslsnr' process (deleted)
2003-02-25 14:19 UTC, Boris Mironov
no flags Details

Description Boris Mironov 2003-02-25 14:11:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
After about 4 days since reboot Oracle TNS-listener process hangs on attempt 
to open new Oracle-session

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
It is really hard to explain
1. Install Oracle 9i Database Release 2 under RedHat AS 2.1 on Dell PowerEdge 
4600 (6Gb RAM in 'spare bank' mode)
2. Linux Kernel parameters: bigpages=2048M profile=2 nmi_watchdog=1
3. Relink Oracle products to utilize asynch IO, and set /proc/sys/kernel/shm-
use-bigpages to 2
    

Actual Results:  After about 4 days of business activity Oracle TNS-listener 
stops to respond via 'tnsping abc', 'lsnrctl stat', ...

Expected Results:  TNS listener should be available 24*7*365

Additional info:

Comment 1 Boris Mironov 2003-02-25 14:19:43 UTC
Created attachment 90350 [details]
Logs from 'crash' utility about status of 'tnslsnr' process

Comment 2 Arjan van de Ven 2003-02-25 14:46:26 UTC
*** Bug 85081 has been marked as a duplicate of this bug. ***

Comment 3 Boris Mironov 2003-02-25 14:51:38 UTC
Kernel version: 2.4.9-e.12smp

Comment 4 Boris Mironov 2003-03-15 17:08:15 UTC
Good news!

Kernel enterprise-2.4.9-e.14amazon seems to be free of the bug.
Currently, Oracle TNS-listener works for more than 7 days without hung.

Thanks,
Boris

Comment 5 Larry Woodman 2003-06-23 18:17:53 UTC
Fixed long ago.

Larry Woodman



Note You need to log in before you can comment on or make changes to this bug.