Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85069 - rpmbuild breaks with unpackaged files.
Summary: rpmbuild breaks with unpackaged files.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 10:40 UTC by Andreas Thienemann
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-25 22:38:48 UTC


Attachments (Terms of Use)

Description Andreas Thienemann 2003-02-25 10:40:55 UTC
Description of problem:
Trying to rebuild source-rpms with installed but not packaged files fails on phoebe.

Testcase:
rpmbuild --rebuild librpm404-4.0.4-8x.27.src.rpm (from Psyche) fails.
The complete buildlog is at http://filepile.dicp.de/rpmbuild.log and
shows that everything runs fine until the end of the %install stage.

The %install stage executes and finished successfully but after checking
for installed but not packaged files the build stops.
It seems that the not-packaged files are being recognized as errors and
not as warnings, something which is not the case with the 8.0
distribution.

Version-Release number of selected component (if applicable): rpm-4.2.0-68

How reproducible: always


Steps to Reproduce:
1. Take a src-rpm which builds cleanly. pident for example as it is small an
builds fast.
2. Comment out one or two files in the %files section. (example testcase at
http://filepile.dicp.de/pidentd-3.0.16-1nousername.src.rpm )
3. rpmbuild -ba $SPECFILE
    
Actual results: Rebuilding stops because of errors

Expected results: Rebuilding continues with warnings

Additional info: Suggested workaround:
Adding "%_unpackaged_files_terminate_build    0" to ~/.rpmmacros or /etc/rpm/macros

Comment 1 Andreas Thienemann 2003-02-25 12:21:33 UTC
After Mike A. Harris explanation about this "feature" I'd just wish for better
documentation of this change.


Note You need to log in before you can comment on or make changes to this bug.