Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85064 - freetype memory leak
Summary: freetype memory leak
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: freetype
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Brock Organ
URL:
Whiteboard:
: 85342 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 08:41 UTC by Havoc Pennington
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-09 21:37:44 UTC


Attachments (Terms of Use)

Description Havoc Pennington 2003-02-25 08:41:09 UTC
Frederic says freetype leaks the whole gzip stream when loading compressed 
fonts... I haven't verified with our package.

<fcrozat> --- freetype-2.1.3/src/gzip/ftgzip.c.pix        2003-02-24
23:23:58.000000000 +0100
<fcrozat> +++ freetype-2.1.3/src/gzip/ftgzip.c    2003-02-24 23:26:22.000000000
+0100
<fcrozat> @@ -276,6 +276,8 @@
<fcrozat>    {
<fcrozat>      z_stream*  zstream = &zip->zstream;
<fcrozat>  
<fcrozat> +    inflateEnd(zstream);
<fcrozat> +
<fcrozat>      /* clear the rest */
<fcrozat>      zstream->zalloc    = NULL;
<fcrozat>      zstream->zfree     = NULL;

Comment 1 Owen Taylor 2003-02-28 15:00:09 UTC
*** Bug 85342 has been marked as a duplicate of this bug. ***

Comment 2 Owen Taylor 2003-06-09 21:37:44 UTC
Was fixed in freetype-2_1_3-8 


Note You need to log in before you can comment on or make changes to this bug.