Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85054 - xslt_XXXX functions not present in 4.2.2 package
Summary: xslt_XXXX functions not present in 4.2.2 package
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 06:14 UTC by Valeriy Ovechkin
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-06 11:10:07 UTC


Attachments (Terms of Use)

Description Valeriy Ovechkin 2003-02-25 06:14:56 UTC
Description of problem:
Just like in bug #21437 <URL:https://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=21437> xslt_XXX functions are still not defined in PHP. 

Please make XSLT support standard (--enable-xslt and --with-xslt-sablot).
Sablot is available at <URL:http://www.gingerall.com/charlie/ga/xml/d_sab.xml>

Version-Release number of selected component (if applicable):
4.2.2

Steps to Reproduce:
1. echo '<?php xslt_create(); ?>' > test.php
2. php test.php
    
Actual results:
... Call to undefined function:  xslt_create() in ...

Expected results:
... Wrong parameter count for xslt_create() in ...

Additional info:
<URL:http://www.php.net/manual/en/ref.xslt.php>
<URL:http://www.gingerall.com/charlie/ga/xml/d_sab.xml>

Comment 1 Joe Orton 2003-03-06 11:10:07 UTC
Since we already ship an XSLT library, libxslt, I doubt we would ship Sablotron
just for this.  Please file an RFE at bugs.php.net asking for libxslt support in
the PHP xslt extension.


Note You need to log in before you can comment on or make changes to this bug.