Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85051 - redhat-config-packages fails to start
Summary: redhat-config-packages fails to start
Keywords:
Status: CLOSED DUPLICATE of bug 74877
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-25 03:24 UTC by Don Wright
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:58 UTC


Attachments (Terms of Use)

Description Don Wright 2003-02-25 03:24:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I start rehat-config-packages, either from a command line or from a desktop
icon, the program starts, displays the box Checking System Package Status and,
after apparently finishing Reading the system state, it terminates.

Version-Release number of selected component (if applicable):1.0.1-1


How reproducible:
Always

Steps to Reproduce:
Initiate redhat-config-packages

Actual Results:  The program terminates in about two or three seconds.

Expected Results:  The package management program should have started.

Additional info:

When I start the program from a command line, I get the following messages:

Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 488, in
readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in readCompsFile
    self.setupStateDicts(packages)
  File "/usr/share/redhat-config-packages/comps.py", line 420, in setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence

Comment 1 Jeremy Katz 2003-02-25 03:32:44 UTC

*** This bug has been marked as a duplicate of 74877 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.